summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Pelaez2017-11-25 16:44:10 -0500
committerMiguel Pelaez2017-11-25 16:44:10 -0500
commit8304c113a10c4a5b5f4978c40a84d5c0f8145ded (patch)
treec7743a527df1e3f154fe3c7ac8d77f4cb560825f
downloadaur-8304c113a10c4a5b5f4978c40a84d5c0f8145ded.tar.gz
First commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD36
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fff87f940ef8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = jdk8-openj9-bin
+ pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk8
+ pkgver = 8u152-b16
+ pkgrel = 1
+ url = https://adoptopenjdk.net/index.html?variant=openjdk8-openj9
+ arch = x86_64
+ license = custom
+ makedepends = coreutils
+ makedepends = bash
+ depends = java-runtime-common
+ depends = java-environment-common
+ depends = ca-certificates-utils
+ depends = nss
+ provides = java-environment=8
+ provides = java-runtime=8
+ provides = java-runtime-headless=8
+ noextract = OpenJDK8-OPENJ9_x64_Linux_jdk8u152-b16.tar.gz
+ source = https://github.com/AdoptOpenJDK/openjdk8-openj9-releases/releases/download/jdk8u152-b16/OpenJDK8-OPENJ9_x64_Linux_jdk8u152-b16.tar.gz
+ sha256sums = b4350498f8781b40e6ed6117eded0748c2f2dfa57dcd441195eac272f9d18e33
+
+pkgname = jdk8-openj9-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..47af16ed06d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.log
+.psci_modules
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3a0e3654a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Miguel Peláez <kernelfreeze@outlook.com>
+# Contributor: WFCody
+
+pkgname=jdk8-openj9-bin
+_pkgver_minor="152"
+_pkgver_build="16"
+pkgver=8.${_pkgver_minor}
+pkgrel=1
+
+pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk8"
+arch=('x86_64')
+url="https://adoptopenjdk.net/index.html?variant=openjdk8-openj9"
+license=('GPL')
+depends=('java-runtime-common' 'java-environment-common' 'ca-certificates-utils' 'nss')
+
+provides=(
+'java-environment=8'
+'java-runtime=8'
+'java-runtime-headless=8'
+)
+
+makedepends=('coreutils' 'bash')
+source=("https://github.com/AdoptOpenJDK/openjdk8-openj9-releases/releases/download/jdk8u${_pkgver_minor}-b${_pkgver_build}/OpenJDK8-OPENJ9_x64_Linux_jdk8u${_pkgver_minor}-b${_pkgver_build}.tar.gz")
+noextract=("OpenJDK8-OPENJ9_x64_Linux_jdk8u${_pkgver_minor}-b${_pkgver_build}.tar.gz")
+
+# https://github.com/AdoptOpenJDK/openjdk8-openj9-releases/releases/download/jdk8u152-b16/OpenJDK8-OPENJ9_x64_Linux_jdk8u152-b16.sha256.txt
+sha256sums=('b4350498f8781b40e6ed6117eded0748c2f2dfa57dcd441195eac272f9d18e33')
+
+package() {
+ cd "$srcdir"
+
+ mkdir -p "${pkgdir}/usr/lib/jvm/"
+ tar -xf OpenJDK8-OPENJ9_x64_Linux_jdk8u${_pkgver_minor}-b${_pkgver_build}.tar.gz -C "${pkgdir}/usr/lib/jvm/"
+ mv "${pkgdir}/usr/lib/jvm/jdk8u${_pkgver_minor}-b${_pkgver_build}" "${pkgdir}/usr/lib/jvm/java-8-j9"
+}
+