summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjandob2015-07-23 11:51:58 +0200
committerjandob2015-07-23 11:51:58 +0200
commit9160820e63d79ec683aebe5c4f063fe6287e35fd (patch)
tree32a87746358dd321c3fccd31cd35120fd70a5d70
downloadaur-9160820e63d79ec683aebe5c4f063fe6287e35fd.tar.gz
ver 0.2.4-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d83d27c3dfb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = jdrivesync
+ pkgdesc = jdrivesync is a simple command line tool that synchronizes a local file system structure to your Google Drive (and back)
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/siom79/jdrivesync
+ arch = any
+ license = Apache
+ depends = java-runtime=8
+ noextract = jdrivesync-0.2.4-jar-with-dependencies.jar
+ source = https://github.com/siom79/jdrivesync/releases/download/jdrivesync-0.2.4/jdrivesync-0.2.4-jar-with-dependencies.jar
+ md5sums = 2ea43b637d0be9cb6ed1a821975c0904
+
+pkgname = jdrivesync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..390ce3247b51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Janosch Dobler <janosch.dobler@gmx.de>
+pkgname=jdrivesync
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="jdrivesync is a simple command line tool that synchronizes a local file system structure to your Google Drive (and back)"
+arch=('any')
+url="https://github.com/siom79/jdrivesync"
+license=('Apache')
+depends=('java-runtime=8')
+options=()
+source=("https://github.com/siom79/jdrivesync/releases/download/$pkgname-$pkgver/$pkgname-$pkgver-jar-with-dependencies.jar")
+noextract=("$pkgname-$pkgver-jar-with-dependencies.jar")
+md5sums=('2ea43b637d0be9cb6ed1a821975c0904')
+
+JARNAME=$pkgname-$pkgver-jar-with-dependencies.jar
+
+build() {
+ echo "#!/bin/sh" > jdrivesync
+ echo "exec /usr/lib/jvm/java-8-openjdk/jre/bin/java -jar '/usr/share/java/jdrivesync/$JARNAME'"' "$@"' >> jdrivesync
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 $JARNAME "${pkgdir}/usr/share/java/jdrivesync/$JARNAME"
+ install -Dm755 jdrivesync "${pkgdir}/usr/bin/jdrivesync"
+}