summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-09-15 19:00:42 -0600
committeryochananmarqos2019-09-15 19:00:42 -0600
commitb8714e51b74c6b7185f6fbeff5579f3e7089e687 (patch)
tree12898becdbafc27e764708f7c2240776c5475d60
downloadaur-b8714e51b74c6b7185f6fbeff5579f3e7089e687.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--jdsp4linux-gui.desktop11
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..092944cfbe30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = jdsp4linux-gui
+ pkgdesc = User Interface for JamesDSP on Linux
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ThePBone/JDSP4Linux-GUI
+ arch = x86_64
+ license = GPL3
+ depends = jdsp4linux
+ depends = qt5-multimedia
+ depends = mesa
+ source = jdsp4linux-gui-1.0.tar.gz::https://github.com/ThePBone/JDSP4Linux-GUI/archive/1.0.tar.gz
+ source = jdsp4linux-gui.desktop
+ sha256sums = d718384b13e650d974d092a6c7e181e0ff42215e22d9db05c1a181da72575f6d
+ sha256sums = fa8ed0bee321c7fed6d2368d0bdf6fd12a3318e324bbda50ec6dbe7e3b784794
+
+pkgname = jdsp4linux-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ad1d87f777a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=jdsp4linux-gui
+pkgver=1.0
+pkgrel=1
+pkgdesc="User Interface for JamesDSP on Linux"
+arch=('x86_64')
+url="https://github.com/ThePBone/JDSP4Linux-GUI"
+license=('GPL3')
+depends=('jdsp4linux' 'qt5-multimedia' 'mesa')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname.desktop")
+sha256sums=('d718384b13e650d974d092a6c7e181e0ff42215e22d9db05c1a181da72575f6d'
+ 'fa8ed0bee321c7fed6d2368d0bdf6fd12a3318e324bbda50ec6dbe7e3b784794')
+
+build() {
+ cd "JDSP4Linux-GUI-$pkgver"
+ qmake
+ make PREFIX=/usr
+}
+
+package() {
+ cd "JDSP4Linux-GUI-$pkgver"
+ install -Dm755 jdsp-gui "$pkgdir/usr/bin/jdsp-gui"
+ install -Dm644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 icons/icon.png \
+ "$pkgdir/usr/share/pixmaps/jdsp-gui.png"
+}
diff --git a/jdsp4linux-gui.desktop b/jdsp4linux-gui.desktop
new file mode 100644
index 000000000000..53e812e4998d
--- /dev/null
+++ b/jdsp4linux-gui.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=JDSP4Linux
+GenericName=Equalizer
+Comment=User Interface for JDSP4Linux
+Keywords=equalizer
+Categories=AudioVideo;Audio;
+Exec=jdsp-gui
+Icon=/usr/share/pixmaps/jdsp-gui.png
+StartupNotify=false
+Terminal=false
+Type=Application