summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-28 10:35:20 -0700
committeryochananmarqos2020-01-28 10:35:20 -0700
commit0b3f913e2fa03c5ebbc515bace97d05265cdb3df (patch)
treeb4a12ddcee775f9976d876b883f99ed9856215c1
parent74656bee701d01adfd923c8e4a32dc8d08d07457 (diff)
downloadaur-0b3f913e2fa03c5ebbc515bace97d05265cdb3df.tar.gz
update email address, PKGBUILD tweaks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 919dc0ac362e..0291ac93e5bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdsp4linux-gui-git
pkgdesc = User Interface for JamesDSP on Linux
- pkgver = 0.1.r6.fa822cd
+ pkgver = 1.1.r2.3abfc92
pkgrel = 1
url = https://github.com/ThePBone/JDSP4Linux-GUI
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = jdsp4linux-gui-git
depends = mesa
provides = jdsp4linux-gui
conflicts = jdsp4linux-gui
- source = git+https://github.com/ThePBone/JDSP4Linux-GUI.git
+ source = jdsp4linux-gui::git+https://github.com/ThePBone/JDSP4Linux-GUI.git
source = jdsp4linux-gui.desktop
sha256sums = SKIP
sha256sums = fa8ed0bee321c7fed6d2368d0bdf6fd12a3318e324bbda50ec6dbe7e3b784794
diff --git a/PKGBUILD b/PKGBUILD
index 6e0822c1e3d3..4e7eab034c40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=jdsp4linux-gui-git
-pkgver=0.1.r6.fa822cd
+pkgver=1.1.r2.3abfc92
pkgrel=1
pkgdesc="User Interface for JamesDSP on Linux"
arch=('x86_64')
@@ -10,27 +10,27 @@ depends=('jdsp4linux' 'qt5-multimedia' 'mesa')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/ThePBone/JDSP4Linux-GUI.git'
+source=("${pkgname%-git}::git+https://github.com/ThePBone/JDSP4Linux-GUI.git"
"${pkgname%-git}.desktop")
sha256sums=('SKIP'
'fa8ed0bee321c7fed6d2368d0bdf6fd12a3318e324bbda50ec6dbe7e3b784794')
pkgver() {
- cd "$srcdir/JDSP4Linux-GUI"
+ cd "$srcdir/${pkgname%-git}"
printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {
- cd "$srcdir/JDSP4Linux-GUI"
+ cd "$srcdir/${pkgname%-git}"
qmake
make PREFIX=/usr
}
package() {
- cd "$srcdir/JDSP4Linux-GUI"
- install -Dm755 jdsp-gui "$pkgdir/usr/bin/jdsp-gui"
- install -Dm644 "$srcdir/${pkgname%-git}.desktop" \
- "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 jdsp-gui -t "$pkgdir/usr/bin"
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t \
+ "$pkgdir/usr/share/applications"
install -Dm644 icons/icon.png \
"$pkgdir/usr/share/pixmaps/jdsp-gui.png"
}