summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2023-06-29 17:30:29 +0200
committerMagnus Boman2023-06-29 17:30:29 +0200
commit2f0034124ab9661b9b8e1a6fcb72e517b3529351 (patch)
treedc6d3935af8937edcc92645881e79ecd18cf455c
parente39926f9c42b592aa7b354bf207136394561202b (diff)
downloadaur-2f0034124ab9661b9b8e1a6fcb72e517b3529351.tar.gz
upgpkg: jdupes-git 1.25.3.r1.gcaab350-1
update xxhash patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--jdupes-system-xxhash.patch (renamed from system-xxhash.patch)34
3 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76a2d55c26ef..cf37df8c090c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdupes-git
pkgdesc = A program for identifying duplicate files residing within specified directories (git)
- pkgver = 1.25.0.r1.g36c7144
+ pkgver = 1.25.3.r1.gcaab350
pkgrel = 1
url = https://github.com/jbruchon/jdupes
arch = i686
@@ -13,8 +13,8 @@ pkgbase = jdupes-git
provides = jdupes
conflicts = jdupes
source = git+https://github.com/jbruchon/jdupes.git
- source = system-xxhash.patch
+ source = jdupes-system-xxhash.patch
sha256sums = SKIP
- sha256sums = b68853cefa710ad4941feee40fc420afc6941d8664f2a1c22d1a5678f57a6057
+ sha256sums = ef7221ca9148bf984d4d82ea973037d6284060945fe8cf59c252881cf42118a4
pkgname = jdupes-git
diff --git a/PKGBUILD b/PKGBUILD
index 1176f464a27b..8e16658afbc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Arnoud Willemsen <mail at lynthium dot com>
pkgname=jdupes-git
-pkgver=1.25.0.r1.g36c7144
+pkgver=1.25.3.r1.gcaab350
pkgrel=1
pkgdesc='A program for identifying duplicate files residing within specified directories (git)'
arch=(i686 x86_64)
@@ -13,16 +13,16 @@ makedepends=(git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+"${url}".git
- system-xxhash.patch)
+ jdupes-system-xxhash.patch)
sha256sums=('SKIP'
- 'b68853cefa710ad4941feee40fc420afc6941d8664f2a1c22d1a5678f57a6057')
+ 'ef7221ca9148bf984d4d82ea973037d6284060945fe8cf59c252881cf42118a4')
pkgver() {
git -C "${pkgname%-git}" describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- patch --directory="${pkgname%-git}" --forward --strip=1 --input="${srcdir}/system-xxhash.patch"
+ patch --directory="${pkgname%-git}" --forward --strip=1 --input="${srcdir}/jdupes-system-xxhash.patch"
}
build() {
diff --git a/system-xxhash.patch b/jdupes-system-xxhash.patch
index f1742ccc7ada..44dc991a71fa 100644
--- a/system-xxhash.patch
+++ b/jdupes-system-xxhash.patch
@@ -1,36 +1,36 @@
diff --git a/Makefile b/Makefile
-index efbd1ce..285e373 100644
+index 7e09923..df9566b 100644
--- a/Makefile
+++ b/Makefile
-@@ -139,7 +139,8 @@ COMPILER_OPTIONS += -DUSE_JODY_HASH
- OBJS_CLEAN += xxhash.o
- else
- ifndef EXTERNAL_HASH_LIB
--OBJS += xxhash.o
-+CFLAGS += `pkg-config --cflags libxxhash`
-+LDFLAGS += `pkg-config --libs libxxhash`
- endif
+@@ -126,7 +126,8 @@ ifdef USE_JODY_HASH
+ OBJS_CLEAN += xxhash.o
+ else
+ ifndef EXTERNAL_HASH_LIB
+- OBJS += xxhash.o
++ CFLAGS += `pkg-config --cflags libxxhash`
++ LDFLAGS += `pkg-config --libs libxxhash`
+ endif
endif # USE_JODY_HASH
diff --git a/jdupes.c b/jdupes.c
-index f47dfed..27bd3c5 100644
+index e3e5762..bc66c05 100644
--- a/jdupes.c
+++ b/jdupes.c
-@@ -42,7 +42,7 @@
- #include <sys/time.h>
- #include "jdupes.h"
+@@ -62,7 +62,7 @@
+ #include "version.h"
+
#ifndef USE_JODY_HASH
- #include "xxhash.h"
+ #include <xxhash.h>
#endif
#ifdef ENABLE_DEDUPE
- #include <sys/utsname.h>
+ #ifdef __linux__
diff --git a/jdupes.h b/jdupes.h
-index 185e630..e375bb0 100644
+index 8b05d87..2975fbb 100644
--- a/jdupes.h
+++ b/jdupes.h
-@@ -30,7 +30,7 @@ extern "C" {
- #include <libjodycode.h>
+@@ -28,7 +28,7 @@ extern "C" {
+ #include <sys/types.h>
#ifndef USE_JODY_HASH
-#include "xxhash.h"