summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2023-07-20 14:22:45 +0200
committerMagnus Boman2023-07-20 14:22:45 +0200
commit30f4b7c26609736b27affc20d7349fed77b12606 (patch)
treee753410d04a773eeb2ffaedc6c603707b1a6953d
parent2f0034124ab9661b9b8e1a6fcb72e517b3529351 (diff)
downloadaur-30f4b7c26609736b27affc20d7349fed77b12606.tar.gz
upgpkg: jdupes-git 1.26.1.r17.gdac5853-1
update system xxhash patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--jdupes-system-xxhash.patch37
3 files changed, 16 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf37df8c090c..0b8efea43379 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdupes-git
pkgdesc = A program for identifying duplicate files residing within specified directories (git)
- pkgver = 1.25.3.r1.gcaab350
+ pkgver = 1.26.1.r17.gdac5853
pkgrel = 1
url = https://github.com/jbruchon/jdupes
arch = i686
@@ -15,6 +15,6 @@ pkgbase = jdupes-git
source = git+https://github.com/jbruchon/jdupes.git
source = jdupes-system-xxhash.patch
sha256sums = SKIP
- sha256sums = ef7221ca9148bf984d4d82ea973037d6284060945fe8cf59c252881cf42118a4
+ sha256sums = b4df170f8ea5569808e0c4f84a1af24282ea53233db760d97531e50df8eea1c4
pkgname = jdupes-git
diff --git a/PKGBUILD b/PKGBUILD
index 8e16658afbc0..e1fc4b2659a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Arnoud Willemsen <mail at lynthium dot com>
pkgname=jdupes-git
-pkgver=1.25.3.r1.gcaab350
+pkgver=1.26.1.r17.gdac5853
pkgrel=1
pkgdesc='A program for identifying duplicate files residing within specified directories (git)'
arch=(i686 x86_64)
@@ -15,7 +15,7 @@ conflicts=("${pkgname%-git}")
source=(git+"${url}".git
jdupes-system-xxhash.patch)
sha256sums=('SKIP'
- 'ef7221ca9148bf984d4d82ea973037d6284060945fe8cf59c252881cf42118a4')
+ 'b4df170f8ea5569808e0c4f84a1af24282ea53233db760d97531e50df8eea1c4')
pkgver() {
git -C "${pkgname%-git}" describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
diff --git a/jdupes-system-xxhash.patch b/jdupes-system-xxhash.patch
index 44dc991a71fa..e2075b5a0ef6 100644
--- a/jdupes-system-xxhash.patch
+++ b/jdupes-system-xxhash.patch
@@ -1,8 +1,8 @@
diff --git a/Makefile b/Makefile
-index 7e09923..df9566b 100644
+index 36ba443..cbdf37a 100644
--- a/Makefile
+++ b/Makefile
-@@ -126,7 +126,8 @@ ifdef USE_JODY_HASH
+@@ -135,7 +135,8 @@ ifdef USE_JODY_HASH
OBJS_CLEAN += xxhash.o
else
ifndef EXTERNAL_HASH_LIB
@@ -12,29 +12,16 @@ index 7e09923..df9566b 100644
endif
endif # USE_JODY_HASH
-diff --git a/jdupes.c b/jdupes.c
-index e3e5762..bc66c05 100644
---- a/jdupes.c
-+++ b/jdupes.c
-@@ -62,7 +62,7 @@
- #include "version.h"
-
- #ifndef USE_JODY_HASH
-- #include "xxhash.h"
-+ #include <xxhash.h>
- #endif
- #ifdef ENABLE_DEDUPE
- #ifdef __linux__
-diff --git a/jdupes.h b/jdupes.h
-index 8b05d87..2975fbb 100644
---- a/jdupes.h
-+++ b/jdupes.h
-@@ -28,7 +28,7 @@ extern "C" {
- #include <sys/types.h>
-
- #ifndef USE_JODY_HASH
+diff --git a/filehash.c b/filehash.c
+index 39edf6b..d00fa71 100644
+--- a/filehash.c
++++ b/filehash.c
+@@ -21,7 +21,7 @@
+ #include "interrupt.h"
+ #include "progress.h"
+ #include "jdupes.h"
-#include "xxhash.h"
+#include <xxhash.h>
- #endif /* USE_JODY_HASH */
- /* Set hash type (change this if swapping in a different hash function) */
+ const char *hash_algo_list[2] = {
+ "xxHash64 v2",