summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2023-05-12 20:19:05 +0200
committerMagnus Boman2023-05-12 20:19:05 +0200
commitc7b32aa7ce2743a3572843a416e0be880a7feebf (patch)
tree61eef74079f6168df94762e408eed5b47e7fb4e6
parent8e0e4f28f646c7f7bbe5ac2871fe9e4e6c54e239 (diff)
downloadaur-c7b32aa7ce2743a3572843a416e0be880a7feebf.tar.gz
upgpkg: jdupes-git 1.23.0.r0.gae3cce7-1
build with system libxxhash
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--system-xxhash.patch40
3 files changed, 54 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dafaffd25dc7..88ca65199163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdupes-git
pkgdesc = A program for identifying duplicate files residing within specified directories (git)
- pkgver = 1.22.0.r7.g3a87ac5
+ pkgver = 1.23.0.r0.gae3cce7
pkgrel = 1
url = https://github.com/jbruchon/jdupes
arch = i686
@@ -9,9 +9,12 @@ pkgbase = jdupes-git
makedepends = git
depends = glibc
depends = libjodycode
+ depends = xxhash
provides = jdupes
conflicts = jdupes
source = git+https://github.com/jbruchon/jdupes.git
+ source = system-xxhash.patch
sha256sums = SKIP
+ sha256sums = b68853cefa710ad4941feee40fc420afc6941d8664f2a1c22d1a5678f57a6057
pkgname = jdupes-git
diff --git a/PKGBUILD b/PKGBUILD
index c6f0a7843fb5..58cac78ce2d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,29 @@
# Contributor: Arnoud Willemsen <mail at lynthium dot com>
pkgname=jdupes-git
-pkgver=1.22.0.r7.g3a87ac5
+pkgver=1.23.0.r0.gae3cce7
pkgrel=1
pkgdesc='A program for identifying duplicate files residing within specified directories (git)'
arch=(i686 x86_64)
url=https://github.com/jbruchon/jdupes
license=(MIT)
-depends=(glibc libjodycode)
+depends=(glibc libjodycode xxhash)
makedepends=(git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=(git+"${url}".git)
-sha256sums=('SKIP')
+source=(git+"${url}".git
+ system-xxhash.patch)
+sha256sums=('SKIP'
+ 'b68853cefa710ad4941feee40fc420afc6941d8664f2a1c22d1a5678f57a6057')
pkgver() {
git -C "${pkgname%-git}" describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch --directory="${pkgname%-git}" --forward --strip=1 --input="${srcdir}/system-xxhash.patch"
+}
+
build() {
cd "${pkgname%-git}"
make ENABLE_BTRFS=1 ENABLE_DEDUPE=1 STATIC_DEDUPE_H=1
diff --git a/system-xxhash.patch b/system-xxhash.patch
new file mode 100644
index 000000000000..f1742ccc7ada
--- /dev/null
+++ b/system-xxhash.patch
@@ -0,0 +1,40 @@
+diff --git a/Makefile b/Makefile
+index efbd1ce..285e373 100644
+--- a/Makefile
++++ b/Makefile
+@@ -139,7 +139,8 @@ COMPILER_OPTIONS += -DUSE_JODY_HASH
+ OBJS_CLEAN += xxhash.o
+ else
+ ifndef EXTERNAL_HASH_LIB
+-OBJS += xxhash.o
++CFLAGS += `pkg-config --cflags libxxhash`
++LDFLAGS += `pkg-config --libs libxxhash`
+ endif
+ endif # USE_JODY_HASH
+
+diff --git a/jdupes.c b/jdupes.c
+index f47dfed..27bd3c5 100644
+--- a/jdupes.c
++++ b/jdupes.c
+@@ -42,7 +42,7 @@
+ #include <sys/time.h>
+ #include "jdupes.h"
+ #ifndef USE_JODY_HASH
+- #include "xxhash.h"
++ #include <xxhash.h>
+ #endif
+ #ifdef ENABLE_DEDUPE
+ #include <sys/utsname.h>
+diff --git a/jdupes.h b/jdupes.h
+index 185e630..e375bb0 100644
+--- a/jdupes.h
++++ b/jdupes.h
+@@ -30,7 +30,7 @@ extern "C" {
+ #include <libjodycode.h>
+
+ #ifndef USE_JODY_HASH
+-#include "xxhash.h"
++#include <xxhash.h>
+ #endif /* USE_JODY_HASH */
+
+ /* Set hash type (change this if swapping in a different hash function) */