summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-06-11 15:08:29 +0200
committerKlaus Alexander Seistrup2024-06-11 15:08:29 +0200
commitc704c78605106002d823485573ede23d0c749623 (patch)
tree78bb9cf0de22d01c57b6f5fbb7969894b98d69e6
parent24f1a194383e3e9209ea98225cff6f4c8d50eac6 (diff)
downloadaur-c704c78605106002d823485573ede23d0c749623.tar.gz
Include the jedstate-prune-nonexistent CLI tool
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
-rw-r--r--jedstate-git.install10
3 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00036dfa6c1d..25c0f4b7f7b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jedstate-git
pkgdesc = S-Lang module for the JED editor to remember its cursor position across invocations (built from latest commit)
- pkgver = 1.0.0.r0.g81d6d40
+ pkgver = 1.0.0.r2.g85c435b
pkgrel = 1
url = https://codeberg.org/kas/jedstate
install = jedstate-git.install
@@ -8,6 +8,7 @@ pkgbase = jedstate-git
license = AGPL-3.0-or-later
makedepends = git
depends = jed
+ depends = slsh
provides = jedstate
conflicts = jedstate
source = git+https://codeberg.org/kas/jedstate.git
diff --git a/PKGBUILD b/PKGBUILD
index fcd0bfb7e68b..946ecf1c4847 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname='jedstate-git'
_pkgname="${pkgname/-git/}"
-pkgver=1.0.0.r0.g81d6d40
+pkgver=1.0.0.r2.g85c435b
pkgrel=1
pkgdesc='S-Lang module for the JED editor to remember its cursor position across invocations (built from latest commit)'
arch=('any')
url='https://codeberg.org/kas/jedstate'
license=('AGPL-3.0-or-later') # SPDX-License-Identifier: AGPL-3.0-or-later
-depends=('jed')
+depends=('jed' 'slsh')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -32,15 +32,19 @@ build() {
package() {
cd "$_pkgname"
- install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -vDm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
cd "src"
- install -Dm0644 jedstate.sl "$pkgdir/usr/share/jed/lib/jedstate.sl"
- install -Dm0644 jedstate.slc "$pkgdir/usr/share/jed/lib/jedstate.slc"
+ install -vDm0644 -t "$pkgdir/usr/share/jed/lib" \
+ jedstate.sl{,c}
- install -Dm0644 jedstate-hooks.sl \
- "$pkgdir/usr/share/doc/$pkgname/jedstate-hooks.sl"
+ install -vDm0644 -t "$pkgdir/usr/share/doc/$pkgname" \
+ jedstate-hooks.sl
+
+ test -f jedstate-prune-nonexistent && \
+ install -vDm0755 -t "$pkgdir/usr/bin" \
+ jedstate-prune-nonexistent
}
# eof
diff --git a/jedstate-git.install b/jedstate-git.install
index 2bce3ac7e293..df6d584b80f1 100644
--- a/jedstate-git.install
+++ b/jedstate-git.install
@@ -2,12 +2,12 @@
pre_install() {
cat <<EOF
-NB: In order to use this package you will have to edit add a
- require("jedstate") to your existing ~/.jedrc, and also
- edit (or add) startup_hook() and exit_hook().
+NB: In order to use this package you will have to add a
+ require("jedstate") to your existing ~/.jedrc, and
+ also edit (or add) startup_hook() and exit_hook().
- Working sample hooks and a README can be found in the
- /usr/share/doc/jedstate-git/ directory.
+ Working sample hooks and a README can be found in
+ the /usr/share/doc/jedstate-git/ directory.
EOF
}