summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2019-01-22 21:17:14 +0100
committerLuca Weiss2019-01-22 21:17:14 +0100
commit05a22adbd81156981e7c3dde2da940b2ba4fb474 (patch)
treeeea6fbd1a46a4f20cd9d660978a3fe113d95069f
parentfc93f4373484de06efebd0add214a175b91a368a (diff)
downloadaur-05a22adbd81156981e7c3dde2da940b2ba4fb474.tar.gz
upgpkg: jellyfin-git 10.0.2.r266.g9714b62fdd-1
Use 'dev' branch, adjust things for that
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c2d56e1767b..476d66f08f6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jellyfin-git
pkgdesc = The Free Software Media Browser
- pkgver = r14852.f25b526ae
+ pkgver = 10.0.2.r266.g9714b62fdd
pkgrel = 1
url = https://github.com/jellyfin/jellyfin
arch = i686
@@ -15,7 +15,8 @@ pkgbase = jellyfin-git
provides = jellyfin
conflicts = jellyfin
backup = etc/conf.d/jellyfin
- source = git+https://github.com/jellyfin/jellyfin.git
+ source = git+https://github.com/jellyfin/jellyfin.git#branch=dev
+ source = git+https://github.com/jellyfin/jellyfin-web.git
source = git+https://github.com/mono/taglib-sharp.git
source = jellyfin.conf
source = jellyfin.service
@@ -23,6 +24,7 @@ pkgbase = jellyfin-git
source = jellyfin.tmpfiles
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = ff3c81ddfd716f179fec8149ea6c2db379e05cd20bd0ffa8ce3ff3a609ca9749
sha256sums = 61febaa0bbe71235d724f236223c7315da393b8b481e4bbed86489a343bca51f
sha256sums = 9bc1ddb77c73d46cc4078356b5773e5a776ebf8b47a1c820ad5fb17591ad5228
diff --git a/PKGBUILD b/PKGBUILD
index 7537db1e8428..150cda015405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Daniel Seymour <dannyseeless@gmail.com>
pkgname=jellyfin-git
-pkgver=r14852.f25b526ae
+pkgver=10.0.2.r266.g9714b62fdd
pkgrel=1
pkgdesc='The Free Software Media Browser'
arch=('i686' 'x86_64' 'armv6h')
@@ -13,7 +13,8 @@ depends=('ffmpeg' 'imagemagick' 'dotnet-sdk' 'sqlite')
makedepends=('git')
provides=('jellyfin')
conflicts=('jellyfin')
-source=('git+https://github.com/jellyfin/jellyfin.git'
+source=('git+https://github.com/jellyfin/jellyfin.git#branch=dev'
+ 'git+https://github.com/jellyfin/jellyfin-web.git'
'git+https://github.com/mono/taglib-sharp.git'
'jellyfin.conf'
'jellyfin.service'
@@ -22,6 +23,7 @@ source=('git+https://github.com/jellyfin/jellyfin.git'
backup=('etc/conf.d/jellyfin')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
'ff3c81ddfd716f179fec8149ea6c2db379e05cd20bd0ffa8ce3ff3a609ca9749'
'61febaa0bbe71235d724f236223c7315da393b8b481e4bbed86489a343bca51f'
'9bc1ddb77c73d46cc4078356b5773e5a776ebf8b47a1c820ad5fb17591ad5228'
@@ -29,29 +31,36 @@ sha256sums=('SKIP'
pkgver() {
cd jellyfin
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd jellyfin
git submodule init
git config submodule.ThirdParty/taglib-sharp.url $srcdir/taglib-sharp
+ git config submodule.MediaBrowser.WebDashboard/jellyfin-web.url $srcdir/jellyfin-web
git submodule update
}
build(){
cd jellyfin
- dotnet build --configuration Release MediaBrowser.sln
- # dotnet doesn't like fakeroot
- dotnet publish --configuration Release MediaBrowser.sln --output "$PWD"/build
- # TODO: Clean up the runtimes folder, Mono.Posix.NETStandard.dll is required from it though
- # rm -rf build/runtimes
+ dotnet build --configuration Release Jellyfin.Server
+ # Ideally, this would be run in package() with the --output variable pointing
+ # to "$pkgdir"/usr/lib/jellyfin, but this step fails in fakeroot.
+ # The makepkg output looks like
+ # Restore completed in 56.84 ms for /aur/jellyfin-git/src/jellyfin/Jellyfin.Server/Jellyfin.Server.csproj.
+ # ==> ERROR: A failure occurred in package().
+ # without indicating any sort of failure.
+ dotnet publish --configuration Release Jellyfin.Server --output "$PWD"/publish
+ # Clean up the runtimes folder (keep linux-*)
+ rm -rfv publish/runtimes/{alpine-*,osx*,tizen-*,win*}
}
package() {
mkdir -p "$pkgdir"/usr/lib
- cp -dr --no-preserve='ownership' jellyfin/build "$pkgdir"/usr/lib/jellyfin
+ cp -dr --no-preserve='ownership' jellyfin/publish "$pkgdir"/usr/lib/jellyfin
install -Dm 644 jellyfin.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm 644 jellyfin.sysusers "${pkgdir}"/usr/lib/sysusers.d/jellyfin.conf