summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2019-01-23 17:24:41 +0100
committerLuca Weiss2019-01-23 17:24:41 +0100
commitc98fe7b5f0a574221612a07f5f8ad3317c4bb47b (patch)
tree54164accd3854320512d42794600d19c83ceb8de
parent05a22adbd81156981e7c3dde2da940b2ba4fb474 (diff)
downloadaur-c98fe7b5f0a574221612a07f5f8ad3317c4bb47b.tar.gz
upgpkg: jellyfin-git 10.0.2.r311.g4658cab6a8-1
Remove taglib-sharp submodule, disable dotnet telemetry
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 476d66f08f6f..52b143be67ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jellyfin-git
pkgdesc = The Free Software Media Browser
- pkgver = 10.0.2.r266.g9714b62fdd
+ pkgver = 10.0.2.r311.g4658cab6a8
pkgrel = 1
url = https://github.com/jellyfin/jellyfin
arch = i686
@@ -17,14 +17,12 @@ pkgbase = jellyfin-git
backup = etc/conf.d/jellyfin
source = git+https://github.com/jellyfin/jellyfin.git#branch=dev
source = git+https://github.com/jellyfin/jellyfin-web.git
- source = git+https://github.com/mono/taglib-sharp.git
source = jellyfin.conf
source = jellyfin.service
source = jellyfin.sysusers
source = jellyfin.tmpfiles
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = ff3c81ddfd716f179fec8149ea6c2db379e05cd20bd0ffa8ce3ff3a609ca9749
sha256sums = 61febaa0bbe71235d724f236223c7315da393b8b481e4bbed86489a343bca51f
sha256sums = 9bc1ddb77c73d46cc4078356b5773e5a776ebf8b47a1c820ad5fb17591ad5228
diff --git a/PKGBUILD b/PKGBUILD
index 150cda015405..1f628e2b9064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Daniel Seymour <dannyseeless@gmail.com>
pkgname=jellyfin-git
-pkgver=10.0.2.r266.g9714b62fdd
+pkgver=10.0.2.r311.g4658cab6a8
pkgrel=1
pkgdesc='The Free Software Media Browser'
arch=('i686' 'x86_64' 'armv6h')
@@ -15,7 +15,6 @@ provides=('jellyfin')
conflicts=('jellyfin')
source=('git+https://github.com/jellyfin/jellyfin.git#branch=dev'
'git+https://github.com/jellyfin/jellyfin-web.git'
- 'git+https://github.com/mono/taglib-sharp.git'
'jellyfin.conf'
'jellyfin.service'
'jellyfin.sysusers'
@@ -23,7 +22,6 @@ source=('git+https://github.com/jellyfin/jellyfin.git#branch=dev'
backup=('etc/conf.d/jellyfin')
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
'ff3c81ddfd716f179fec8149ea6c2db379e05cd20bd0ffa8ce3ff3a609ca9749'
'61febaa0bbe71235d724f236223c7315da393b8b481e4bbed86489a343bca51f'
'9bc1ddb77c73d46cc4078356b5773e5a776ebf8b47a1c820ad5fb17591ad5228'
@@ -38,7 +36,6 @@ pkgver() {
prepare() {
cd jellyfin
git submodule init
- git config submodule.ThirdParty/taglib-sharp.url $srcdir/taglib-sharp
git config submodule.MediaBrowser.WebDashboard/jellyfin-web.url $srcdir/jellyfin-web
git submodule update
}
@@ -46,6 +43,9 @@ prepare() {
build(){
cd jellyfin
+ # Disable dotnet telemetry
+ export DOTNET_CLI_TELEMETRY_OPTOUT=1
+
dotnet build --configuration Release Jellyfin.Server
# Ideally, this would be run in package() with the --output variable pointing
# to "$pkgdir"/usr/lib/jellyfin, but this step fails in fakeroot.
@@ -62,10 +62,10 @@ package() {
mkdir -p "$pkgdir"/usr/lib
cp -dr --no-preserve='ownership' jellyfin/publish "$pkgdir"/usr/lib/jellyfin
- install -Dm 644 jellyfin.service -t "${pkgdir}"/usr/lib/systemd/system/
- install -Dm 644 jellyfin.sysusers "${pkgdir}"/usr/lib/sysusers.d/jellyfin.conf
- install -Dm 644 jellyfin.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/jellyfin.conf
- install -Dm 644 jellyfin.conf "${pkgdir}"/etc/conf.d/jellyfin
+ install -Dm 644 jellyfin.service -t "$pkgdir"/usr/lib/systemd/system/
+ install -Dm 644 jellyfin.sysusers "$pkgdir"/usr/lib/sysusers.d/jellyfin.conf
+ install -Dm 644 jellyfin.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/jellyfin.conf
+ install -Dm 644 jellyfin.conf "$pkgdir"/etc/conf.d/jellyfin
}
# vim: ts=2 sw=2 et: