summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2024-04-17 21:21:46 -0400
committerAndrew Rabert2024-04-17 21:21:46 -0400
commitb7fcdd0bc58b63b9cfa927e7ea12685c8ef2e8d9 (patch)
treeaf9cff80398c1e865f25026a27ec258c27174dab
parent315078468131dfc18b39c8c2cd7553e776ebe686 (diff)
downloadaur-b7fcdd0bc58b63b9cfa927e7ea12685c8ef2e8d9.tar.gz
1.9.1-3
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--fix-mpv-0_38_0.patch15
4 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49f47e0fbf56..4af1abfc502c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jellyfin-media-player
pkgdesc = Jellyfin Desktop Client
pkgver = 1.9.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jellyfin/jellyfin-media-player
arch = i686
arch = x86_64
@@ -19,7 +19,9 @@ pkgbase = jellyfin-media-player
depends = qt5-quickcontrols
source = https://github.com/jellyfin/jellyfin-media-player/archive/refs/tags/v1.9.1.tar.gz
source = jellyfin-web_10.8.13.tar.gz::https://repo.jellyfin.org/releases/server/portable/versions/stable/web/10.8.13/jellyfin-web_10.8.13_portable.tar.gz
+ source = fix-mpv-0_38_0.patch
sha256sums = 8d119bb78e897ace3041cf332114a79c51be4d8e0cc8c68f5745fd588c2b9bde
sha256sums = cbd00c3c3a56d7d17d63dc6060b5cbc011820a83cde64b7f9c93690fbac174d6
+ sha256sums = 3cb05f527df63ce34b50099a5676ee65d2c5a902c47d238e355a615c8b439f66
pkgname = jellyfin-media-player
diff --git a/.gitignore b/.gitignore
index 4df5cbd2d036..e69e4b9d7c75 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.SRCINFO
!.gitignore
!PKGBUILD
+!fix-mpv-0_38_0.patch
diff --git a/PKGBUILD b/PKGBUILD
index d40e3060160c..4f4030999e21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=jellyfin-media-player
pkgver=1.9.1
_webver=10.8.13
-pkgrel=2
+pkgrel=3
pkgdesc='Jellyfin Desktop Client'
arch=('i686' 'x86_64')
license=('GPL')
@@ -11,9 +11,16 @@ url='https://github.com/jellyfin/jellyfin-media-player'
depends=('mpv' 'libcec' 'sdl2' 'p8-platform' 'protobuf' 'qt5-webengine' 'qt5-x11extras' 'qt5-quickcontrols')
makedepends=('cmake' 'git' 'python')
source=("https://github.com/jellyfin/jellyfin-media-player/archive/refs/tags/v${pkgver}.tar.gz"
- "jellyfin-web_${_webver}.tar.gz::https://repo.jellyfin.org/releases/server/portable/versions/stable/web/${_webver}/jellyfin-web_${_webver}_portable.tar.gz")
+ "jellyfin-web_${_webver}.tar.gz::https://repo.jellyfin.org/releases/server/portable/versions/stable/web/${_webver}/jellyfin-web_${_webver}_portable.tar.gz"
+ "fix-mpv-0_38_0.patch")
sha256sums=('8d119bb78e897ace3041cf332114a79c51be4d8e0cc8c68f5745fd588c2b9bde'
- 'cbd00c3c3a56d7d17d63dc6060b5cbc011820a83cde64b7f9c93690fbac174d6')
+ 'cbd00c3c3a56d7d17d63dc6060b5cbc011820a83cde64b7f9c93690fbac174d6'
+ '3cb05f527df63ce34b50099a5676ee65d2c5a902c47d238e355a615c8b439f66')
+
+prepare() {
+ cd "${srcdir}/jellyfin-media-player-${pkgver}"
+ patch -Np1 < "../fix-mpv-0_38_0.patch"
+}
build() {
cd "${srcdir}/jellyfin-media-player-${pkgver}"
diff --git a/fix-mpv-0_38_0.patch b/fix-mpv-0_38_0.patch
new file mode 100644
index 000000000000..e9a83fa61f9d
--- /dev/null
+++ b/fix-mpv-0_38_0.patch
@@ -0,0 +1,15 @@
+diff --git a/src/player/PlayerComponent.cpp b/src/player/PlayerComponent.cpp
+index bf55aab..bb0d4a3 100644
+--- a/src/player/PlayerComponent.cpp
++++ b/src/player/PlayerComponent.cpp
+@@ -318,6 +318,10 @@ void PlayerComponent::queueMedia(const QString& url, const QVariantMap& options,
+ command << "loadfile" << qurl.toString(QUrl::FullyEncoded);
+ command << "append-play"; // if nothing is playing, play it now, otherwise just enqueue it
+
++#if MPV_CLIENT_API_VERSION >= MPV_MAKE_VERSION(2, 3)
++ command << -1; // insert_at_idx
++#endif
++
+ QVariantMap extraArgs;
+
+ quint64 startMilliseconds = options["startMilliseconds"].toLongLong();