summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2021-04-06 10:33:55 -0400
committerAndrew Rabert2021-04-06 10:34:22 -0400
commitbab67dac3eeee62a1f7f9873b897d001445b956d (patch)
tree3a59cb76c4cf9c34e3536aa7f1d4944643a7c496
parentd2077d2588163e8d6fc97df9d928003afe18f66b (diff)
downloadaur-bab67dac3eeee62a1f7f9873b897d001445b956d.tar.gz
1.2.1
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--VersionConfiguration.cmake.patch18
4 files changed, 9 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5be95695b96..1af39b778ecc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jellyfin-media-player
pkgdesc = Jellyfin Desktop Client
- pkgver = 1.2.0
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/iwalton3/jellyfin-media-player
arch = i686
@@ -16,12 +16,10 @@ pkgbase = jellyfin-media-player
depends = qt5-webengine
depends = qt5-x11extras
depends = qt5-quickcontrols
- source = https://github.com/iwalton3/jellyfin-media-player/archive/refs/tags/v1.2.0.tar.gz
- source = https://github.com/iwalton3/jellyfin-web-jmp/releases/download/jwc-1.7.0-2/dist.zip
- source = VersionConfiguration.cmake.patch
- sha256sums = 5d6d6d0ffa10ff001cfb1e936c324bac6245b126e97f1c4c45b538bf64548e2e
- sha256sums = d20c47c10247e2d91588b4bead4f7e9c29be1f76803de1924692edb10ee94dc4
- sha256sums = b8d9c283b4574cf791b46625295cfae8709e96e0e243c80d31754be13066ebcd
+ source = https://github.com/iwalton3/jellyfin-media-player/archive/refs/tags/v1.2.1.tar.gz
+ source = https://github.com/iwalton3/jellyfin-web-jmp/releases/download/jwc-1.7.0-3/dist.zip
+ sha256sums = 77f8dfe427992c6ee4df09e257798cd15734c4afcaad211959605f63edef8fb1
+ sha256sums = 4a79a6210fe0d3300da947086a6ec07f45993fffc771789c645bfac05f2cf08a
pkgname = jellyfin-media-player
diff --git a/.gitignore b/.gitignore
index 5dc617953ce5..4df5cbd2d036 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.SRCINFO
!.gitignore
!PKGBUILD
-!VersionConfiguration.cmake.patch
diff --git a/PKGBUILD b/PKGBUILD
index ab457470bebb..0d5e6b2d6f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Rabert <ar@nullsum.net>
pkgname=jellyfin-media-player
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=1
pkgdesc='Jellyfin Desktop Client'
arch=('i686' 'x86_64')
@@ -10,18 +10,9 @@ url='https://github.com/iwalton3/jellyfin-media-player'
depends=('mpv' 'libcec' 'sdl2' 'p8-platform' 'protobuf' 'qt5-webengine' 'qt5-x11extras' 'qt5-quickcontrols')
makedepends=('cmake' 'git')
source=("https://github.com/iwalton3/jellyfin-media-player/archive/refs/tags/v${pkgver}.tar.gz"
- 'https://github.com/iwalton3/jellyfin-web-jmp/releases/download/jwc-1.7.0-2/dist.zip'
- 'VersionConfiguration.cmake.patch')
-sha256sums=('5d6d6d0ffa10ff001cfb1e936c324bac6245b126e97f1c4c45b538bf64548e2e'
- 'd20c47c10247e2d91588b4bead4f7e9c29be1f76803de1924692edb10ee94dc4'
- 'b8d9c283b4574cf791b46625295cfae8709e96e0e243c80d31754be13066ebcd')
-
-prepare() {
- cd "${srcdir}/jellyfin-media-player-${pkgver}"
-
- # fix building without git repo
- patch -u CMakeModules/VersionConfiguration.cmake -i ../VersionConfiguration.cmake.patch
-}
+ 'https://github.com/iwalton3/jellyfin-web-jmp/releases/download/jwc-1.7.0-3/dist.zip')
+sha256sums=('77f8dfe427992c6ee4df09e257798cd15734c4afcaad211959605f63edef8fb1'
+ '4a79a6210fe0d3300da947086a6ec07f45993fffc771789c645bfac05f2cf08a')
build() {
cd "${srcdir}/jellyfin-media-player-${pkgver}"
diff --git a/VersionConfiguration.cmake.patch b/VersionConfiguration.cmake.patch
deleted file mode 100644
index fd5ece3cd859..000000000000
--- a/VersionConfiguration.cmake.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a 21:49:41.000000000 -0400
-+++ b 2021-04-05 13:56:57.658766476 -0400
-@@ -2,15 +2,6 @@
- # include(WebClientVariables)
- string(TIMESTAMP CURRENT_DATE "%Y-%m-%d")
-
--# Get git revision version
--include(GetGitRevisionDescription)
--get_git_head_revision(REFSPEC FULL_GIT_REVISION)
--if(FULL_GIT_REVISION STREQUAL "GITDIR-NOTFOUND")
-- set(GIT_REVISION "git")
--else(FULL_GIT_REVISION STREQUAL "GITDIR-NOTFOUND")
-- string(SUBSTRING ${FULL_GIT_REVISION} 0 8 GIT_REVISION)
--endif(FULL_GIT_REVISION STREQUAL "GITDIR-NOTFOUND")
--
- # Get the build number if available
- if(DEFINED ENV{BUILD_NUMBER})
- set(VERSION_BUILD "$ENV{BUILD_NUMBER}")