summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2021-04-05 22:59:22 -0400
committerAndrew Rabert2021-04-05 22:59:32 -0400
commitd2077d2588163e8d6fc97df9d928003afe18f66b (patch)
tree999f8f197a3d2b833154a0cd20a58d782b5040ce
parentfee0a2174405202ab5a0933a323bb28d2828a1d9 (diff)
downloadaur-d2077d2588163e8d6fc97df9d928003afe18f66b.tar.gz
1.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--CMakeLists.txt.patch11
-rw-r--r--PKGBUILD23
-rw-r--r--main.cpp.patch20
-rw-r--r--src_CMakeLists.txt.patch43
6 files changed, 11 insertions, 105 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0071f724887..e5be95695b96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jellyfin-media-player
pkgdesc = Jellyfin Desktop Client
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/iwalton3/jellyfin-media-player
arch = i686
@@ -16,18 +16,12 @@ pkgbase = jellyfin-media-player
depends = qt5-webengine
depends = qt5-x11extras
depends = qt5-quickcontrols
- source = https://github.com/iwalton3/jellyfin-media-player/archive/refs/tags/v1.1.0.tar.gz
- source = https://github.com/iwalton3/jellyfin-web-jmp/releases/download/v1.1.0/dist.zip
- source = CMakeLists.txt.patch
+ source = https://github.com/iwalton3/jellyfin-media-player/archive/refs/tags/v1.2.0.tar.gz
+ source = https://github.com/iwalton3/jellyfin-web-jmp/releases/download/jwc-1.7.0-2/dist.zip
source = VersionConfiguration.cmake.patch
- source = main.cpp.patch
- source = src_CMakeLists.txt.patch
- sha256sums = 0b26d2c8cccb239bcf85138482f894c1ba6d0c0df8c44e4c38cd86d2fae6ee7c
- sha256sums = d2f5e7b3fbe44307dafd99b5212cf11e0c01f780e27211cdf3acb9753d03f0bf
- sha256sums = aca0a3ead028ca54c7ffd1eab719809a9bea3b23f5b9a0490c7f3054b47cb2a4
+ sha256sums = 5d6d6d0ffa10ff001cfb1e936c324bac6245b126e97f1c4c45b538bf64548e2e
+ sha256sums = d20c47c10247e2d91588b4bead4f7e9c29be1f76803de1924692edb10ee94dc4
sha256sums = b8d9c283b4574cf791b46625295cfae8709e96e0e243c80d31754be13066ebcd
- sha256sums = 90e5f7966c7999b030dc705a9c2b272f2293884a200617f7587ff9d4edc57467
- sha256sums = 854dd8df54a0e2922e24d40fae6dc390c347f91a932311c239598382c9f83b3e
pkgname = jellyfin-media-player
diff --git a/.gitignore b/.gitignore
index 0ef45ad5526f..5dc617953ce5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,5 @@
*
!.SRCINFO
!.gitignore
-!CMakeLists.txt.patch
!PKGBUILD
!VersionConfiguration.cmake.patch
-!main.cpp.patch
-!src_CMakeLists.txt.patch
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
deleted file mode 100644
index e70e50e3f2df..000000000000
--- a/CMakeLists.txt.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a 21:49:41.000000000 -0400
-+++ b 2021-04-05 13:43:11.972965381 -0400
-@@ -52,8 +52,6 @@
- include(NameConfiguration)
- include(PlayerConfiguration)
- include(InputConfiguration)
--include(FindBreakpad)
--include(BreakpadSymbols)
- include(ClangTidy)
-
- add_definitions(-DQS_LOG_LINE_NUMBERS -DQS_LOG_SEPARATE_THREAD)
diff --git a/PKGBUILD b/PKGBUILD
index 51906ce9c6a4..ab457470bebb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Rabert <ar@nullsum.net>
pkgname=jellyfin-media-player
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc='Jellyfin Desktop Client'
arch=('i686' 'x86_64')
@@ -10,26 +10,15 @@ url='https://github.com/iwalton3/jellyfin-media-player'
depends=('mpv' 'libcec' 'sdl2' 'p8-platform' 'protobuf' 'qt5-webengine' 'qt5-x11extras' 'qt5-quickcontrols')
makedepends=('cmake' 'git')
source=("https://github.com/iwalton3/jellyfin-media-player/archive/refs/tags/v${pkgver}.tar.gz"
- "https://github.com/iwalton3/jellyfin-web-jmp/releases/download/v${pkgver}/dist.zip"
- 'CMakeLists.txt.patch'
- 'VersionConfiguration.cmake.patch'
- 'main.cpp.patch'
- 'src_CMakeLists.txt.patch')
-sha256sums=('0b26d2c8cccb239bcf85138482f894c1ba6d0c0df8c44e4c38cd86d2fae6ee7c'
- 'd2f5e7b3fbe44307dafd99b5212cf11e0c01f780e27211cdf3acb9753d03f0bf'
- 'aca0a3ead028ca54c7ffd1eab719809a9bea3b23f5b9a0490c7f3054b47cb2a4'
- 'b8d9c283b4574cf791b46625295cfae8709e96e0e243c80d31754be13066ebcd'
- '90e5f7966c7999b030dc705a9c2b272f2293884a200617f7587ff9d4edc57467'
- '854dd8df54a0e2922e24d40fae6dc390c347f91a932311c239598382c9f83b3e')
+ 'https://github.com/iwalton3/jellyfin-web-jmp/releases/download/jwc-1.7.0-2/dist.zip'
+ 'VersionConfiguration.cmake.patch')
+sha256sums=('5d6d6d0ffa10ff001cfb1e936c324bac6245b126e97f1c4c45b538bf64548e2e'
+ 'd20c47c10247e2d91588b4bead4f7e9c29be1f76803de1924692edb10ee94dc4'
+ 'b8d9c283b4574cf791b46625295cfae8709e96e0e243c80d31754be13066ebcd')
prepare() {
cd "${srcdir}/jellyfin-media-player-${pkgver}"
- # disable breakpad crash reporter (now in master branch)
- patch -u CMakeLists.txt -i ../CMakeLists.txt.patch
- patch -u src/CMakeLists.txt -i ../src_CMakeLists.txt.patch
- patch -u src/main.cpp -i ../main.cpp.patch
-
# fix building without git repo
patch -u CMakeModules/VersionConfiguration.cmake -i ../VersionConfiguration.cmake.patch
}
diff --git a/main.cpp.patch b/main.cpp.patch
deleted file mode 100644
index 752209ccb92e..000000000000
--- a/main.cpp.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a 21:49:41.000000000 -0400
-+++ b 2021-04-05 13:49:14.963759430 -0400
-@@ -16,7 +16,6 @@
- #include "player/CodecsComponent.h"
- #include "player/PlayerComponent.h"
- #include "player/OpenGLDetect.h"
--#include "breakpad/CrashDumps.h"
- #include "Version.h"
- #include "settings/SettingsComponent.h"
- #include "settings/SettingsSection.h"
-@@ -164,9 +163,6 @@
- PFMoveToApplicationsFolderIfNecessary();
- #endif
-
-- // init breakpad.
-- setupCrashDumper();
--
- UniqueApplication* uniqueApp = new UniqueApplication();
- if (!uniqueApp->ensureUnique())
- return EXIT_SUCCESS;
diff --git a/src_CMakeLists.txt.patch b/src_CMakeLists.txt.patch
deleted file mode 100644
index 9e451818f69c..000000000000
--- a/src_CMakeLists.txt.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a 21:49:41.000000000 -0400
-+++ b 2021-04-05 13:45:37.045106120 -0400
-@@ -14,17 +14,6 @@
-
- add_definitions(-DPREFIX="${CMAKE_INSTALL_PREFIX}")
-
--find_package(Breakpad)
--
--if(BREAKPAD_FOUND)
-- include_directories(${BREAKPAD_INCLUDE_DIR})
-- set(BREAKPAD_LIBRARIES ${BREAKPAD_LIBRARY})
-- if(UNIX)
-- # cmake issue: breakpad-client.pc adds this, but cmake discards it
-- set(BREAKPAD_LIBRARIES ${BREAKPAD_LIBRARIES} -lpthread)
-- endif()
--endif()
--
- add_subdirectory(shared)
- add_subdirectory(core)
- add_subdirectory(display)
-@@ -33,7 +22,6 @@
- add_subdirectory(ui)
- add_subdirectory(input)
- add_subdirectory(system)
--add_subdirectory(breakpad)
- add_subdirectory(settings)
- add_subdirectory(power)
-
-@@ -187,7 +175,6 @@
- ${EXTRA_LIBS}
- ${X11_LIBRARIES}
- ${X11_Xrandr_LIB}
-- ${BREAKPAD_LIBRARIES}
- ${ICU_LIBRARIES}
- ${CMAKE_THREAD_LIBS_INIT}
- ${RPI_LIBS}
-@@ -200,6 +187,4 @@
- set(LIBPATH ${CMAKE_FIND_ROOT_PATH})
- set(SOURCE_ROOT ${CMAKE_SOURCE_DIR})
-
--dumpsyms(${MAIN_TARGET} ${CMAKE_BINARY_DIR}/${MAIN_TARGET}.symbols)
--
- include(CompleteBundle)