summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0xGingi2023-08-24 17:11:58 -0400
committer0xGingi2023-08-24 17:11:58 -0400
commit02a217268aed477e08c591cda8e6cfb4440e135c (patch)
tree477ff0efe09de340c2a1b15f3ee6510e9331a369
parent3e81714050322990eee4f8d9eb32a995d7a48335 (diff)
downloadaur-02a217268aed477e08c591cda8e6cfb4440e135c.tar.gz
Check if systemd service file exists
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cff564397765..71597b0fb88b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jellyfin-rpc-bin
pkgdesc = Displays the content you're currently watching on Discord
pkgver = 0.14.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Radiicall/jellyfin-rpc
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 1ca991bc1489..e731eb981ea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: 0xGingi <0xgingi@0xgingi.com>
pkgname=('jellyfin-rpc-bin')
pkgver=0.14.4
-pkgrel=1
+pkgrel=2
pkgdesc="Displays the content you're currently watching on Discord"
arch=('x86_64')
url="https://github.com/Radiicall/jellyfin-rpc"
@@ -23,7 +23,12 @@ package() {
cd $srcdir
install -Dm0755 ./jellyfin-rpc-x86_64-linux "$pkgdir/usr/lib/jellyfin-rpc/jellyfin-rpc"
install -Dm0644 ./jellyfin-rpc/example.json "$pkgdir/usr/lib/jellyfin-rpc/example.json"
- install -Dm0644 ./jellyfin-rpc/scripts/jellyfin-rpc.service "$pkgdir/usr/lib/systemd/user/jellyfin-rpc.service"
+ FILE=/usr/lib/systemd/user/jellyfin-rpc.service
+ if [ -f "$FILE" ]; then
+ echo "Systemd Service File Detected"
+ else
+ install -Dm0644 "scripts/jellyfin-rpc.service" -t "$pkgdir/usr/lib/systemd/user/"
+ fi
echo
echo