summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Asbach2017-01-02 01:11:39 +0100
committerBenjamin Asbach2017-01-02 01:35:55 +0100
commitb8a92685970a0bd3093f90ab162963969e434ea0 (patch)
tree784baaf310f37fbb18c3fc3575ebf399718c7b89
downloadaur-b8a92685970a0bd3093f90ab162963969e434ea0.tar.gz
Introduced aur for jenkins-lts-2.32.1
(based on jenkins PKGBUILD files)
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore1
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD41
-rw-r--r--jenkins.conf13
-rw-r--r--jenkins.install9
-rw-r--r--jenkins.service24
-rw-r--r--jenkins.sysusers2
-rw-r--r--jenkins.tmpfiles1
9 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..131b2f2a61e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = jenkins-lts
+ pkgdesc = Extendable continuous integration server (lts)
+ pkgver = 2.32.1
+ pkgrel = 1
+ url = https://jenkins.io
+ install = jenkins.install
+ arch = any
+ license = MIT
+ depends = java-runtime-headless
+ depends = ttf-dejavu
+ depends = libcups
+ provides = jenkins-ci
+ conflicts = jenkins-ci
+ replaces = jenkins-ci
+ noextract = jenkins-2.32.1.war
+ backup = etc/conf.d/jenkins
+ source = jenkins-2.32.1.war::http://mirrors.jenkins.io/war-stable/2.32.1/jenkins.war
+ source = jenkins.conf
+ source = jenkins.service
+ source = jenkins.tmpfiles
+ source = jenkins.sysusers
+ source = LICENSE
+ sha512sums = d5e34e6b38f3827b3aa8d00f4dd6825fb590f56fe97403385d55a204bd32c850606cd992fee9a9c4d74e2777c4843ff29be120ca5c7e8d71f52946a19d3295be
+ sha512sums = 3a8421cef3953d899c150609f959cf5d5dd6d08d079a5e0f48bfece4f3c80491722b9e90ef841fddb87401c226b8338297c5c4e83e55a33ef8d6e387de3048d0
+ sha512sums = a336b006d3711abb75b49a2e12c09ee61cf3275a2cdbbd3676480e2f6ca8ba0fb4b9c08f3f9da193252c4fca827e9a1d5eaad847d0a889445693427ae1571fe7
+ sha512sums = a845a7147be54affc586dfce9a188ec24c92e673e88dec0b62da386d2e597de6ecda103429008562abd897f179a52c37cf2188ebc65b8c636efd07d707e18f90
+ sha512sums = 896cbc64eadb2f3bb9fa7fc26dbfc527b1823d8bff3158be7f1936cc250f55eeafe89079e1ceb8f3d269041662573ccbbb36248140b4ba24144a564366f8847a
+ sha512sums = 0df6479a600db395c12ad29ebda3120d00460338b9a6b15913e2245aa29212a3798c32e664ca70c8034146e2e0b573066deec9e3210198202f753994e1b83efa
+
+pkgname = jenkins-lts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2247feea7b7f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+The MIT License
+
+Copyright (c) 2004-, Kohsuke Kawaguchi, Sun Microsystems, Inc., and a number of other of contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1259e9e33ccd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Benjamin Asbach <archlinux-aur.${pkgname}@impl.it>
+
+pkgname=jenkins-lts
+pkgver=2.32.1
+pkgrel=1
+pkgdesc='Extendable continuous integration server (lts)'
+arch=('any')
+url='https://jenkins.io'
+license=('MIT')
+depends=('java-runtime-headless' 'ttf-dejavu' 'libcups')
+provides=('jenkins-ci')
+conflicts=('jenkins-ci')
+replaces=('jenkins-ci')
+backup=('etc/conf.d/jenkins')
+install='jenkins.install'
+noextract=("jenkins-${pkgver}.war")
+source=("jenkins-${pkgver}.war::http://mirrors.jenkins.io/war-stable/${pkgver}/jenkins.war"
+ # Rename to force re-download on new version
+ 'jenkins.conf'
+ 'jenkins.service'
+ 'jenkins.tmpfiles'
+ 'jenkins.sysusers'
+ 'LICENSE')
+sha512sums=('d5e34e6b38f3827b3aa8d00f4dd6825fb590f56fe97403385d55a204bd32c850606cd992fee9a9c4d74e2777c4843ff29be120ca5c7e8d71f52946a19d3295be'
+ '3a8421cef3953d899c150609f959cf5d5dd6d08d079a5e0f48bfece4f3c80491722b9e90ef841fddb87401c226b8338297c5c4e83e55a33ef8d6e387de3048d0'
+ 'a336b006d3711abb75b49a2e12c09ee61cf3275a2cdbbd3676480e2f6ca8ba0fb4b9c08f3f9da193252c4fca827e9a1d5eaad847d0a889445693427ae1571fe7'
+ 'a845a7147be54affc586dfce9a188ec24c92e673e88dec0b62da386d2e597de6ecda103429008562abd897f179a52c37cf2188ebc65b8c636efd07d707e18f90'
+ '896cbc64eadb2f3bb9fa7fc26dbfc527b1823d8bff3158be7f1936cc250f55eeafe89079e1ceb8f3d269041662573ccbbb36248140b4ba24144a564366f8847a'
+ '0df6479a600db395c12ad29ebda3120d00460338b9a6b15913e2245aa29212a3798c32e664ca70c8034146e2e0b573066deec9e3210198202f753994e1b83efa')
+
+package() {
+ install -Dm444 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm444 "jenkins-${pkgver}.war" "$pkgdir/usr/share/java/jenkins/jenkins.war"
+ install -Dm644 jenkins.service "$pkgdir/usr/lib/systemd/system/jenkins.service"
+ install -Dm644 jenkins.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/jenkins.conf"
+ install -Dm644 jenkins.sysusers "$pkgdir/usr/lib/sysusers.d/jenkins.conf"
+ install -Dm644 jenkins.conf "$pkgdir/etc/conf.d/jenkins"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/jenkins.conf b/jenkins.conf
new file mode 100644
index 000000000000..5975142010e3
--- /dev/null
+++ b/jenkins.conf
@@ -0,0 +1,13 @@
+JAVA=/usr/bin/java
+JAVA_ARGS=-Xmx512m
+JAVA_OPTS=
+JENKINS_USER=jenkins
+JENKINS_HOME=/var/lib/jenkins
+JENKINS_WAR=/usr/share/java/jenkins/jenkins.war
+JENKINS_WEBROOT=--webroot=/var/cache/jenkins
+JENKINS_PORT=--httpPort=8090
+JENKINS_AJPPORT=--ajp13Port=-1
+JENKINS_OPTS=
+JENKINS_COMMAND_LINE="$JAVA $JAVA_ARGS $JAVA_OPTS -jar $JENKINS_WAR $JENKINS_WEBROOT $JENKINS_PORT $JENKINS_AJPPORT $JENKINS_OPTS"
+
+# vim:set ts=2 sw=2 et:
diff --git a/jenkins.install b/jenkins.install
new file mode 100644
index 000000000000..e86d9caa75c8
--- /dev/null
+++ b/jenkins.install
@@ -0,0 +1,9 @@
+post_install() {
+ systemd-sysusers jenkins.conf
+ [[ -d var/lib/jenkins ]] || install -dm 750 -o jenkins -g jenkins var/lib/jenkins
+ systemd-tmpfiles --create jenkins.conf
+}
+
+post_upgrade() {
+ (( $(vercmp $2 '1.633-1') < 0 )) && systemd-sysusers jenkins.conf || true
+}
diff --git a/jenkins.service b/jenkins.service
new file mode 100644
index 000000000000..3b98338a78a6
--- /dev/null
+++ b/jenkins.service
@@ -0,0 +1,24 @@
+[Unit]
+Description=Extendable continuous integration server
+After=network.target
+
+[Service]
+User=jenkins
+Type=simple
+EnvironmentFile=/etc/conf.d/jenkins
+StandardOutput=syslog
+StandardError=syslog
+SyslogIdentifier=jenkins
+ExecStart=/bin/sh -c 'eval $JENKINS_COMMAND_LINE'
+#MemoryLimit=768M
+OOMScoreAdjust=-1000
+LimitCPU=infinity
+LimitFSIZE=infinity
+LimitDATA=infinity
+LimitCORE=0
+LimitAS=infinity
+LimitLOCKS=infinity
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/jenkins.sysusers b/jenkins.sysusers
new file mode 100644
index 000000000000..ee4c8923c27a
--- /dev/null
+++ b/jenkins.sysusers
@@ -0,0 +1,2 @@
+u jenkins - "Jenkins CI" /var/lib/jenkins
+g jenkins -
diff --git a/jenkins.tmpfiles b/jenkins.tmpfiles
new file mode 100644
index 000000000000..c325acd26bb5
--- /dev/null
+++ b/jenkins.tmpfiles
@@ -0,0 +1 @@
+d /var/cache/jenkins 0755 jenkins jenkins -