summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtrament2019-08-08 12:00:53 +0100
committerAtrament2019-08-08 12:00:53 +0100
commit5a3bdfefcac7a928d8c312ae5c7629676b445f06 (patch)
treeff3dcca2515bd44d93f6cc77a130b5615949eeb0
downloadaur-5a3bdfefcac7a928d8c312ae5c7629676b445f06.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--fix_desktop_file.patch19
-rw-r--r--fix_stockfish_path.patch13
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f085b7e705d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = jerry-git
+ pkgdesc = A chess program build around powerful chess engine Stockfish
+ pkgver = v3.2.0.r8.gf19447f
+ pkgrel = 1
+ url = http://jerry-chess.github.io
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-svg
+ provides = jerry
+ source = git+https://github.com/asdfjkl/jerry.git#branch=master
+ source = fix_desktop_file.patch
+ source = fix_stockfish_path.patch
+ sha256sums = SKIP
+ sha256sums = 4c62aa9bf79969c71c60962a68d46aeff2c54c398bf76b106f58764f2f25b80d
+ sha256sums = 2bff53051f51a1a0e85a0fcfea2dd912917ae6ac436a9f66f60479c565ae8dfd
+
+pkgname = jerry-git
+ depends = stockfish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5f46a542660
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: atrament666
+
+pkgname=jerry-git
+pkgver=v3.2.0.r8.gf19447f
+pkgrel=1
+pkgdesc='A chess program build around powerful chess engine Stockfish'
+arch=('i686' 'x86_64')
+url=http://jerry-chess.github.io
+license=('GPL')
+depends=('qt5-svg')
+provides=('jerry')
+sha256sums=('SKIP'
+ '4c62aa9bf79969c71c60962a68d46aeff2c54c398bf76b106f58764f2f25b80d'
+ '2bff53051f51a1a0e85a0fcfea2dd912917ae6ac436a9f66f60479c565ae8dfd')
+
+source=('git+https://github.com/asdfjkl/jerry.git#branch=master'
+ 'fix_desktop_file.patch'
+ 'fix_stockfish_path.patch')
+
+prepare() {
+ cd $srcdir/jerry
+ patch --strip=1 -i $srcdir/fix_stockfish_path.patch
+ patch --strip=1 -i $srcdir/fix_desktop_file.patch
+}
+
+pkgver() {
+ cd $srcdir/jerry
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ cd $srcdir/jerry
+ mkdir -p bin
+ cd bin
+ qmake ../jerry3.pro
+ make
+}
+
+package() {
+ depends=('stockfish')
+ install -v ${srcdir}/jerry/bin/Jerry -m 755 -D ${pkgdir}/usr/bin/jerry
+ install -v ${srcdir}/jerry/debian_package_files/jerry.desktop -m 755 -D ${pkgdir}/usr/share/applications/jerry.desktop
+ install -v ${srcdir}/jerry/res/icons/jerry_icon256.png -m 755 -D ${pkgdir}/usr/share/jerry/icons/jerry_icon256.png
+}
diff --git a/fix_desktop_file.patch b/fix_desktop_file.patch
new file mode 100644
index 000000000000..c08cf6d862a3
--- /dev/null
+++ b/fix_desktop_file.patch
@@ -0,0 +1,19 @@
+diff --git a/debian_package_files/jerry.desktop b/debian_package_files/jerry.desktop
+index dd67f6d..15fe913 100644
+--- a/debian_package_files/jerry.desktop
++++ b/debian_package_files/jerry.desktop
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+ Type=Application
+ Terminal=false
+-Name=Jerry - Chess GUI
+-Exec=/usr/games/jerry
+-Comment=Chess Program
+-Icon=jerry
++Name=jerry
++Exec=/usr/bin/jerry
++Comment=A chess program build around powerful chess engine Stockfish
++Icon=/usr/share/jerry/icons/jerry_icon256.png
+ StartupNotify=false
+ Encoding=UTF-8
+ Categories=Game
diff --git a/fix_stockfish_path.patch b/fix_stockfish_path.patch
new file mode 100644
index 000000000000..9593d366efe5
--- /dev/null
+++ b/fix_stockfish_path.patch
@@ -0,0 +1,13 @@
+diff --git a/model/internalengine.cpp b/model/internalengine.cpp
+index dc85769..7ab66e2 100644
+--- a/model/internalengine.cpp
++++ b/model/internalengine.cpp
+@@ -30,7 +30,7 @@ InternalEngine::InternalEngine() : Engine()
+ this->name = QString("Stockfish");
+
+ #ifdef __linux__
+- QString path = QString("/usr/games/stockfish");
++ QString path = QString("/usr/bin/stockfish");
+ this->setPath(path);
+ #endif
+