summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchristoph2015-07-16 22:24:23 +0200
committerchristoph2015-07-16 22:24:23 +0200
commit74a038d64281a11e4ba54920b49503af6208afba (patch)
treeef5713cda54c9127f2dd305f27b783c0accd5be5
downloadaur-74a038d64281a11e4ba54920b49503af6208afba.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE11
-rw-r--r--PKGBUILD35
-rw-r--r--jes.desktop11
-rw-r--r--jes.sh.new3
5 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59a836f5e3d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = jes
+ pkgdesc = A java-based tool for german cash method of accounting (Einnahme-Überschuss-Rechnung)
+ pkgver = 1.00.40
+ pkgrel = 1
+ url = http://www.jes-eur.de
+ arch = any
+ license = custom
+ depends = java-runtime
+ depends = x-server
+ depends = xdg-utils
+ source = https://dl.dropboxusercontent.com/u/2628626/jes/jes_10040.zip
+ source = jes.desktop
+ source = jes.sh.new
+ source = LICENSE
+ md5sums = a98fe3051629d982fefdc752a4fd9b2d
+ md5sums = fb13c662b57cf5a59ba54004de735b82
+ md5sums = 611c2047318cbad2e5ae2f186f26593d
+ md5sums = 7d5b1e5c39c18e5f943bb35f6bccd62a
+
+pkgname = jes
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..173cffdf7f3a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,11 @@
+Jes - Die Java-EÜR ist kostenlose Software, die wie sie ist ("as is") bereitgestellt wird.
+Es wird nicht behauptet, daß Jes - Die Java-EÜR für einen bestimmten Zweck tauglich ist oder
+irgendwelche Anforderungen erfüllt. Sie sind selbst dafür verantwortlich, Jes - Die Java-EÜR
+zu testen und die Tauglichkeit für den geplanten Einsatzzweck zu beurteilen. Der Autor kann
+nicht verantwortlich gemacht werden für verlorene Daten, Ausfallzeiten oder andere Schäden,
+die mittelbar oder unmittelbar durch den Einsatz von Jes - Die Java-EÜR entstanden sind.
+Es ist nicht gestattet, Jes - Die Java-EÜR zu verändern oder zurückzuentwickeln. Es ist
+ausdrücklich gestattet und erwünscht, Jes - Die Java-EÜR an andere Interessenten weiterzugeben,
+solange dafür kein Geld oder eine sonstige Gegenleistung verlangt wird.
+
+Wenn Sie Jes - Die Java-EÜR herunterladen, erklären Sie sich mit diesen Bedingungen einverstanden.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fdbf89d96b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christoph Steinacker <archologist.linuxATgooglemailDOTcom>
+pkgname=jes
+pkgver=1.00.40
+pkgrel=1
+pkgdesc="A java-based tool for german cash method of accounting (Einnahme-Überschuss-Rechnung)"
+arch=('any')
+url="http://www.jes-eur.de"
+license=('custom')
+#install="${pkgname}.install"
+depends=('java-runtime' 'x-server' 'xdg-utils')
+source=(https://dl.dropboxusercontent.com/u/2628626/jes/jes_10040.zip
+ ${pkgname}.desktop
+ ${pkgname}.sh.new
+ LICENSE
+)
+package() {
+ # Removing delivered shell script
+ rm $srcdir/$pkgname.sh
+
+ cd ${srcdir}
+ install -D -m755 jes.jar ${pkgdir}/usr/share/java/${pkgname}/jes.jar
+
+ install -D -m755 ${pkgname}.sh.new ${pkgdir}/usr/bin/${pkgname}
+ install -D -m644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+
+ # Installing the LICENSE
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ # Installing the icons
+ install -D -m644 ${pkgname}.png ${pkgdir}/usr/share/icons/hicolor/128x128/apps/${pkgname}.png
+}
+md5sums=('a98fe3051629d982fefdc752a4fd9b2d'
+ 'fb13c662b57cf5a59ba54004de735b82'
+ '611c2047318cbad2e5ae2f186f26593d'
+ '7d5b1e5c39c18e5f943bb35f6bccd62a') \ No newline at end of file
diff --git a/jes.desktop b/jes.desktop
new file mode 100644
index 000000000000..104ef9b9eaf0
--- /dev/null
+++ b/jes.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application # Indicates the type as listed above
+Version=1.0 # The version of the desktop entry specification to which this file complies
+Name=Jes # The name of the application
+Name[de]=Jes # The name of the application
+Comment=Accountig tool # A comment which can/will be used as a tooltip
+Comment[de]=Einnahme-Überschuss-Rechnung # A comment which can/will be used as a tooltip
+Exec=jes # The executable of the application.
+Icon=jes # The name of the icon that will be used to display this entry
+Terminal=false # Describes whether this application needs to be run in a terminal or not
+Categories=Office # Describes the categories in which this entry should be shown
diff --git a/jes.sh.new b/jes.sh.new
new file mode 100644
index 000000000000..5380d9c30bb0
--- /dev/null
+++ b/jes.sh.new
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/java/jes
+java -jar jes.jar \ No newline at end of file