summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond Li2021-11-26 20:32:51 -0500
committerRaymond Li2021-11-26 20:32:51 -0500
commit580c256add310c5f855861713c41bffdb59e2fcd (patch)
treedcf1cfc8788b3416a53c6d83ec9acb16d4dbc706
parente86d04f2fcd063e987560e62e8d8f669e354b162 (diff)
downloadaur-580c256add310c5f855861713c41bffdb59e2fcd.tar.gz
Update script
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD2
-rw-r--r--jflap2tikz.sh2
4 files changed, 1 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15020f9b8f3c..d8c59a202d57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,10 +7,8 @@ pkgbase = jflap2tikz
license = custom
depends = groovy
source = http://mirrors.ctan.org/graphics/jflap2tikz.zip
- source = LICENSE
source = jflap2tikz.sh
sha256sums = 625264995030491208857f370715e328b03b388f16d60e4c381c1df3519da141
- sha256sums = 362a0f90a53c27370b7685c940082ba7941f487a7aeb87aab8882a1094db7e3a
sha256sums = dd5cf8ffd83daf560fe1399ce27bcffbc02b14e810f5f0935b40b17cd27c1449
pkgname = jflap2tikz
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 31aa7129042a..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,20 +0,0 @@
-Copyright (c) 2009, 2014, 2015 Andrew Mertz and William Slough
-
-Permission is hereby granted, free of charge, to any person obtaining
-a copy of this software and associated documentation files (the
-"Software"), to deal in the Software without restriction, including
-without limitation the rights to use, copy, modify, merge, publish,
-distribute, sublicense, and/or sell copies of the Software, and to
-permit persons to whom the Software is furnished to do so, subject to
-the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 8f12e5c87656..c520e4dc141b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,8 @@ url="https://www.ctan.org/pkg/jflap2tikz?lang=en"
license=('custom')
depends=('groovy')
source=("http://mirrors.ctan.org/graphics/${pkgname}.zip"
- "LICENSE"
"jflap2tikz.sh")
sha256sums=('625264995030491208857f370715e328b03b388f16d60e4c381c1df3519da141'
- '362a0f90a53c27370b7685c940082ba7941f487a7aeb87aab8882a1094db7e3a'
'dd5cf8ffd83daf560fe1399ce27bcffbc02b14e810f5f0935b40b17cd27c1449')
package() {
diff --git a/jflap2tikz.sh b/jflap2tikz.sh
index 93ccd63c9cb3..8ae95fa2d16f 100644
--- a/jflap2tikz.sh
+++ b/jflap2tikz.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-exec /usr/bin/java -jar '/usr/share/java/jflap2tikz/jflap2tikz.jar' "$@"
+exec groovy '/usr/lib/jflap2tikz/jflap2tikz.groovy' "$@"