summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpurpleleaf2022-03-07 22:58:32 +0100
committerpurpleleaf2022-03-07 22:58:32 +0100
commit0b8c7559b6dece207d66d0e046a7ba974d7e205f (patch)
tree3fdce7f7c7e9be54b9aacce804f47e6536e76225
downloadaur-0b8c7559b6dece207d66d0e046a7ba974d7e205f.tar.gz
First release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd0ec465ad02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = jgmenu-git
+ pkgdesc = Simple, independent, contemporary-looking X11 menu, designed for scripting, ricing and tweaking. Compiled with gtktheme, lx and pmenu support
+ pkgver = 4.4.0.r0.g2c73e23
+ pkgrel = 1
+ url = https://github.com/johanmalm/jgmenu
+ arch = x86_64
+ license = GPL2
+ depends = libx11
+ depends = cairo
+ depends = pango
+ depends = libxrandr
+ depends = librsvg
+ depends = libxml2
+ depends = glib2
+ depends = menu-cache
+ depends = python
+ provides = jgmenu
+ conflicts = jgmenu
+ source = jgmenu::git+https://github.com/johanmalm/jgmenu.git
+ sha256sums = SKIP
+
+pkgname = jgmenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ee179622fd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: purpleleaf <max@ganoia.eu>
+_pkgname=jgmenu
+pkgname=$_pkgname-git
+pkgver=`git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's:^v::'`
+pkgrel=1
+pkgdesc="Simple, independent, contemporary-looking X11 menu, designed for scripting, ricing and tweaking. Compiled with gtktheme, lx and pmenu support"
+arch=('x86_64')
+url="https://github.com/johanmalm/$_pkgname"
+license=('GPL2')
+depends=('libx11' 'cairo' 'pango' 'libxrandr' 'librsvg' 'libxml2' 'glib2' 'menu-cache' 'python')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${_pkgname}::git+${url}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd ${pkgname}
+ echo $pkgver
+}
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --with-gtktheme --with-lx --with-pmenu --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+