summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2017-03-31 11:34:45 -0300
committerRafael Fontenelle2017-03-31 11:36:55 -0300
commit41fdc94eafbf6088da310e21c7b9eb21521491a0 (patch)
tree5434d4638be2a33074a8a72ccde70b961639e686
parentf832f90586627674874c5186d01b440cde1d9b2e (diff)
downloadaur-41fdc94eafbf6088da310e21c7b9eb21521491a0.tar.gz
Update to 3.15.92+1081+ge10b7222
Changes in this commit: 1- Update to commit e10b7222, to have meson built within jhbuild and PYTHON/PYTHON3 dinstinguish implemented (however, the patch file module_autogenargs.patch is still required) 2- Fix JHBuild's srcdir value, removing $pkgname-$_commit from it 3- Remove meson from depends() due to the item 1 above
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 765a0883671e..c3b1aeb4dea3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Feb 23 03:46:53 UTC 2017
+# Fri Mar 31 13:57:09 UTC 2017
pkgbase = jhbuild
pkgdesc = Tool to build the whole GNOME desktop from sources
- pkgver = 3.15.92+1012+g88207c11
- pkgrel = 2
+ pkgver = 3.15.92+1081+ge10b7222
+ pkgrel = 1
url = https://wiki.gnome.org/Projects/Jhbuild
arch = any
license = GPL
@@ -74,7 +74,7 @@ pkgbase = jhbuild
optdepends = bzr: fetch Bazaar repositories
optdepends = mercurial: fetch Mercurial repositories
optdepends = darcs: fetch Darcs repositories
- source = jhbuild-88207c11::git+https://git.gnome.org/browse/jhbuild#commit=88207c11
+ source = jhbuild-e10b7222::git+https://git.gnome.org/browse/jhbuild#commit=e10b7222
source = module_autogenargs.patch
sha256sums = SKIP
sha256sums = 273d53cb976642692eb9ed8536a02b0fe677c47662bbef8b50d1a8bcb292665f
diff --git a/PKGBUILD b/PKGBUILD
index 57ef9cda697e..718c2c70fbd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=jhbuild
-pkgver=3.15.92+1012+g88207c11
-pkgrel=2
+pkgver=3.15.92+1081+ge10b7222
+pkgrel=1
pkgdesc='Tool to build the whole GNOME desktop from sources'
arch=('any')
url='https://wiki.gnome.org/Projects/Jhbuild'
@@ -17,7 +17,7 @@ optdepends=('subversion: fetch subversion repositories'
'bzr: fetch Bazaar repositories'
'mercurial: fetch Mercurial repositories'
'darcs: fetch Darcs repositories')
-_commit=88207c11
+_commit=e10b7222
source=("$pkgname-$_commit::git+https://git.gnome.org/browse/jhbuild#commit=$_commit"
"module_autogenargs.patch")
sha256sums=('SKIP'
@@ -30,8 +30,14 @@ pkgver() {
prepare() {
cd $pkgname-$_commit
- msg2 "Set parameters known to be required for Arch Linux"
+ msg2 "Set parameters known to be required in Arch Linux"
patch -p1 -i "$srcdir/module_autogenargs.patch"
+
+ # Set proper python binary according to the version
+ # (see jhbuild commit id=ffd00eea72bfdfac02846a46559904bd8fa09d57)
+ sed -i jhbuild/modtypes/distutils.py \
+ -e "/os.environ.get('PYTHON'/s/'python'/'python2'/" \
+ -e "/os.environ.get('PYTHON3'/s/'python3'/'python'/"
}
build() {
@@ -46,8 +52,8 @@ package() {
install -Dm644 examples/sample.jhbuildrc "$pkgdir/usr/share/jhbuild/examples/sample.jhbuildrc"
install -Dm644 examples/wayland.jhbuildrc "$pkgdir/usr/share/jhbuild/examples/wayland.jhbuildrc"
install -Dm644 contrib/jhbuild_completion.bash "$pkgdir/usr/share/bash-completion/completions/jhbuild"
- sed -i "s|$srcdir|$HOME/jhbuild|g" "${pkgdir}"/usr/bin/jhbuild
+ sed -i "s|$srcdir/$pkgname-$_commit|$HOME/jhbuild|g" "$pkgdir"/usr/bin/jhbuild
}
# list of dependencies reported by 'jhbuild sysdeps'
-depends+=(anthy argyllcms caribou cmake cups docbook-utils docbook-xsl dotconf doxygen espeak exempi git gmime gperf gtkspell3 hyphen intltool itstool kyotocabinet libatasmart libcanberra libdmapsharing libdvdread libgexiv2 libgphoto2 libhangul libical libmusicbrainz5 libndp liboauth libpwquality libraw libvirt libvpx meson mpc openldap opus plymouth poppler-glib ppp python-cairo ragel ruby smbclient startup-notification taglib v4l-utils vala wavpack wget wireless_tools xf86-input-wacom xmlto xorg-server-xwayland xorg-util-macros xtrans)
+depends+=(anthy argyllcms caribou cmake cups docbook-utils docbook-xsl dotconf doxygen espeak exempi git gmime gperf gtkspell3 hyphen intltool itstool kyotocabinet libatasmart libcanberra libdmapsharing libdvdread libgexiv2 libgphoto2 libhangul libical libmusicbrainz5 libndp liboauth libpwquality libraw libvirt libvpx mpc openldap opus plymouth poppler-glib ppp python-cairo ragel ruby smbclient startup-notification taglib v4l-utils vala wavpack wget wireless_tools xf86-input-wacom xmlto xorg-server-xwayland xorg-util-macros xtrans)