summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Tojnar2017-02-09 14:29:59 +0100
committerJan Tojnar2017-02-09 14:29:59 +0100
commit1df5a7fadeeb88112569d2f33099243fd3428176 (patch)
treeba1ce618df46ce8490957764bec82303d140af21
downloadaur-1df5a7fadeeb88112569d2f33099243fd3428176.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
-rw-r--r--jhbuild.install7
-rw-r--r--module_autogenargs.patch18
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69ac5e363ab2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Feb 9 13:26:33 UTC 2017
+pkgbase = jhbuild-git
+ pkgdesc = Tool to build the whole GNOME desktop from sources
+ pkgver = 3.15.92.r1012.g88207c11
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/Jhbuild
+ install = jhbuild.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gnome-common
+ makedepends = intltool
+ makedepends = yelp-tools
+ depends = python2
+ depends = git
+ optdepends = subversion: fetch subversion repositories
+ optdepends = cvs: fetch CVS repositories
+ optdepends = bzr: fetch Bazaar repositories
+ optdepends = mercurial: fetch Mercurial repositories
+ optdepends = darcs: fetch Darcs repositories
+ provides = jhbuild
+ source = git://git.gnome.org/jhbuild
+ sha256sums = SKIP
+
+pkgname = jhbuild-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ed1cb45f8e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Mark Weiman <mark dot weiman at markzz dot com>
+# Contributor: Kerrick Staley <mail@kerrickstaley.com>
+# Contributor: Thijs Vermeir <thijsvermeir@gmail.com>
+# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
+# Maintainer: Jan Tojnar <jtojnar@gmail.com>
+
+_pkgname=jhbuild
+pkgname=${_pkgname}-git
+pkgver=3.15.92.r1012.g88207c11
+pkgrel=1
+pkgdesc='Tool to build the whole GNOME desktop from sources'
+arch=('i686' 'x86_64')
+url='https://wiki.gnome.org/Projects/Jhbuild'
+license=('GPL')
+depends=(python2 git)
+makedepends=(gnome-common intltool yelp-tools)
+optdepends=('subversion: fetch subversion repositories'
+ 'cvs: fetch CVS repositories'
+ 'bzr: fetch Bazaar repositories'
+ 'mercurial: fetch Mercurial repositories'
+ 'darcs: fetch Darcs repositories')
+provides=('jhbuild')
+install=jhbuild.install
+source=("git://git.gnome.org/jhbuild")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr PYTHON=/usr/bin/python2
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+ cp -dr modulesets "$pkgdir/usr/share/jhbuild"
+ sed -i "s|$srcdir|$HOME/jhbuild|g" "${pkgdir}"/usr/bin/jhbuild
+}
diff --git a/jhbuild.install b/jhbuild.install
new file mode 100644
index 000000000000..2a6ad207b991
--- /dev/null
+++ b/jhbuild.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo 'Now, look at'
+ echo
+ echo ' http://git.gnome.org/browse/jhbuild/tree/examples/sample.jhbuildrc'
+ echo
+ echo 'and create your ~/.config/jhbuildrc file.'
+}
diff --git a/module_autogenargs.patch b/module_autogenargs.patch
new file mode 100644
index 000000000000..244dd7cbc356
--- /dev/null
+++ b/module_autogenargs.patch
@@ -0,0 +1,18 @@
+diff --git a/jhbuild/defaults.jhbuildrc b/jhbuild/defaults.jhbuildrc
+index e467a49..de715c4 100644
+--- a/jhbuild/defaults.jhbuildrc
++++ b/jhbuild/defaults.jhbuildrc
+@@ -78,7 +78,12 @@ repos = {}
+ cvsroots = {}
+ svnroots = {}
+ branches = {}
+-module_autogenargs = {}
++# Arch-specific setting: we need to pass PYTHON=/usr/bin/python2 when building some modules.
++module_autogenargs = {
++ 'itstool': autogenargs + ' PYTHON=/usr/bin/python2',
++ 'telepathy-mission-control': autogenargs + ' PYTHON=/usr/bin/python2',
++ 'WebKit': autogenargs + ' PYTHON=/usr/bin/python2',
++}
+ module_cmakeargs = {}
+ module_makeargs = {}
+ module_extra_env = {}