summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-01-16 00:24:25 -0600
committerLuis Martinez2023-01-16 00:24:25 -0600
commit484770ff880fa7237b88d373805e91408105c982 (patch)
treecb96610266c34f792d9c8551321e1a518b9785d1
parent7fdf76c969a13f6709e929d06ac81de2e541937f (diff)
downloadaur-484770ff880fa7237b88d373805e91408105c982.tar.gz
package cleanup
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ee357d7c64f..ddc3561f3d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = jid-bin
pkgdesc = Json incremental digger
pkgver = 0.7.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/simeji/jid
arch = i686
arch = x86_64
+ arch = aarch64
license = MIT
depends = glibc
provides = jid
conflicts = jid
- conflicts = jid-git
- source_i686 = https://github.com/simeji/jid/releases/download/v0.7.6/jid_linux_386.zip
+ source = LICENSE
+ sha256sums = 3db4ceef736801baccfff1bc4d6ea64dc889dcc43cfc49151907ab98538f8c2d
+ source_i686 = jid-bin-0.7.6-i686.zip::https://github.com/simeji/jid/releases/download/v0.7.6/jid_linux_386.zip
sha256sums_i686 = e23f72e688d5808400d12d4050b6dfd2cf1ef31e8c53727cd05eb29e1313e033
- source_x86_64 = https://github.com/simeji/jid/releases/download/v0.7.6/jid_linux_amd64.zip
+ source_x86_64 = jid-bin-0.7.6-x86_64.zip::https://github.com/simeji/jid/releases/download/v0.7.6/jid_linux_amd64.zip
sha256sums_x86_64 = b5706cda44bc76c5db8a1e7956d25ef2e25bf618a7b03e1d98e8f4fc2e2f393a
+ source_aarch64 = jid-bin-0.7.6-aarch64.zip::https://github.com/simeji/jid/releases/download/v0.7.6/jid_linux_arm64.zip
+ sha256sums_aarch64 = 071ee2a01982efd9e503d5fd3003a0e3a449df83b577aae4f25f56cebf7a76df
pkgname = jid-bin
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c9d11dafc1b5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2016 simeji
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 0935022ebcc8..0ab87ee87332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-# Maintainer: sdvcrx <memory.silentvoyage@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: sdvcrx <memory.silentvoyage@gmail.com>
pkgname=jid-bin
_pkgname=jid
pkgver=0.7.6
-pkgrel=1
+pkgrel=2
pkgdesc="Json incremental digger"
url="https://github.com/simeji/jid"
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "aarch64")
license=("MIT")
provides=("jid")
-conflicts=("jid" "jid-git")
+conflicts=("jid")
depends=("glibc")
-source_i686=("https://github.com/simeji/jid/releases/download/v${pkgver}/${_pkgname}_linux_386.zip")
-source_x86_64=("https://github.com/simeji/jid/releases/download/v${pkgver}/${_pkgname}_linux_amd64.zip")
+source=('LICENSE')
+source_i686=("$pkgname-$pkgver-i686.zip::$url/releases/download/v${pkgver}/${_pkgname}_linux_386.zip")
+source_x86_64=("$pkgname-$pkgver-x86_64.zip::$url/releases/download/v${pkgver}/${_pkgname}_linux_amd64.zip")
+source_aarch64=("$pkgname-$pkgver-aarch64.zip::$url/releases/download/v${pkgver}/${_pkgname}_linux_arm64.zip")
+sha256sums=('3db4ceef736801baccfff1bc4d6ea64dc889dcc43cfc49151907ab98538f8c2d')
sha256sums_i686=('e23f72e688d5808400d12d4050b6dfd2cf1ef31e8c53727cd05eb29e1313e033')
sha256sums_x86_64=('b5706cda44bc76c5db8a1e7956d25ef2e25bf618a7b03e1d98e8f4fc2e2f393a')
+sha256sums_aarch64=('071ee2a01982efd9e503d5fd3003a0e3a449df83b577aae4f25f56cebf7a76df')
package() {
- cd "${srcdir}"
-
- install -Dm755 "${srcdir}/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ install -Dv "$srcdir/$_pkgname" -t "$pkgdir/usr/bin/"
+ install -Dvm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-