summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranz Wimmer2021-03-21 19:54:23 +0100
committerFranz Wimmer2021-03-21 19:54:23 +0100
commiteefeb50ce57da9161ce43f698608d328224499ec (patch)
tree26393a1a19c30d5ec9257de9e6acaffaa573d6a4
downloadaur-eefeb50ce57da9161ce43f698608d328224499ec.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore94
-rw-r--r--PKGBUILD54
3 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..485db6d61e51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = jim
+ pkgdesc = SSH wrapper to connect to pre-defined servers
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/CryoCodec/jim
+ arch = x86
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = go
+ makedepends = make
+ depends = openssh
+ depends = sshpass
+ provides = jim
+ conflicts = jim
+ source = jim::git+https://github.com/zalintyre/jim.git
+ md5sums = SKIP
+
+pkgname = jim
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b69dadc07ab2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,94 @@
+
+# Created by https://www.toptal.com/developers/gitignore/api/intellij+all
+# Edit at https://www.toptal.com/developers/gitignore?templates=intellij+all
+
+### Intellij+all ###
+# Covers JetBrains IDEs: IntelliJ, RubyMine, PhpStorm, AppCode, PyCharm, CLion, Android Studio, WebStorm and Rider
+# Reference: https://intellij-support.jetbrains.com/hc/en-us/articles/206544839
+
+# User-specific stuff
+.idea/**/workspace.xml
+.idea/**/tasks.xml
+.idea/**/usage.statistics.xml
+.idea/**/dictionaries
+.idea/**/shelf
+
+# Generated files
+.idea/**/contentModel.xml
+
+# Sensitive or high-churn files
+.idea/**/dataSources/
+.idea/**/dataSources.ids
+.idea/**/dataSources.local.xml
+.idea/**/sqlDataSources.xml
+.idea/**/dynamic.xml
+.idea/**/uiDesigner.xml
+.idea/**/dbnavigator.xml
+
+# Gradle
+.idea/**/gradle.xml
+.idea/**/libraries
+
+# Gradle and Maven with auto-import
+# When using Gradle or Maven with auto-import, you should exclude module files,
+# since they will be recreated, and may cause churn. Uncomment if using
+# auto-import.
+# .idea/artifacts
+# .idea/compiler.xml
+# .idea/jarRepositories.xml
+# .idea/modules.xml
+# .idea/*.iml
+# .idea/modules
+# *.iml
+# *.ipr
+
+# CMake
+cmake-build-*/
+
+# Mongo Explorer plugin
+.idea/**/mongoSettings.xml
+
+# File-based project format
+*.iws
+
+# IntelliJ
+out/
+
+# mpeltonen/sbt-idea plugin
+.idea_modules/
+
+# JIRA plugin
+atlassian-ide-plugin.xml
+
+# Cursive Clojure plugin
+.idea/replstate.xml
+
+# Crashlytics plugin (for Android Studio and IntelliJ)
+com_crashlytics_export_strings.xml
+crashlytics.properties
+crashlytics-build.properties
+fabric.properties
+
+# Editor-based Rest Client
+.idea/httpRequests
+
+# Android studio 3.1+ serialized cache file
+.idea/caches/build_file_checksums.ser
+
+### Intellij+all Patch ###
+# Ignores the whole .idea folder and all .iml files
+# See https://github.com/joeblau/gitignore.io/issues/186 and https://github.com/joeblau/gitignore.io/issues/360
+
+.idea/
+
+# Reason: https://github.com/joeblau/gitignore.io/issues/186#issuecomment-249601023
+
+*.iml
+modules.xml
+.idea/misc.xml
+*.ipr
+
+# Sonarlint plugin
+.idea/sonarlint
+
+# End of https://www.toptal.com/developers/gitignore/api/intellij+all
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67ab5069bccc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname='jim'
+pkgver=0
+pkgrel=1
+pkgdesc="SSH wrapper to connect to pre-defined servers"
+arch=('x86' 'x86_64')
+url="https://github.com/CryoCodec/$pkgname"
+license=('Apache')
+groups=()
+depends=('openssh' 'sshpass')
+makedepends=('git' 'go' 'make')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+https://github.com/zalintyre/${pkgname}.git")
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ echo $pkgver
+ git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+ echo $(pwd)
+ cd "$srcdir/${pkgname}"
+ make
+}
+
+# check() {
+# cd "$srcdir/${pkgname}"
+# make -k check
+# }
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make DESTDIR="$pkgdir" install
+}