summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2017-10-21 22:16:05 -0700
committerAnatol Pomozov2017-10-21 22:16:05 -0700
commit02c0c4c1b794ae98e4d948250299e54859b56fdc (patch)
treed205a541c289ff4a8451e04812a21d781808df8f
parentc497e9ac35c431f6715d0578103abd718d2e6e93 (diff)
downloadaur-02c0c4c1b794ae98e4d948250299e54859b56fdc.tar.gz
Add a workaround for libgit2 build issue
-rw-r--r--PKGBUILD8
-rw-r--r--fix_libgit2_build.patch39
2 files changed, 46 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd2badfd7d53..672a49b2fa8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,8 @@ source=(
git+https://fuchsia.googlesource.com/third_party/libssh2#commit=615210a03ecf36e1c55ffb7101d53e5c231c2f43
git+https://fuchsia.googlesource.com/third_party/libgit2#commit=25a4b97b1bd0b5316deb77866756a3db772e08a2
git+https://fuchsia.googlesource.com/third_party/zlib#commit=871bb1c83c0a4cc180c66ac89b14cb08675bef0d
+
+ fix_libgit2_build.patch
)
sha1sums=('SKIP'
'SKIP'
@@ -24,7 +26,8 @@ sha1sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '798fbefdda5144f30e9fe6bde7ef0df01c0e9caf')
pkgver() {
cd jiri
@@ -60,6 +63,9 @@ prepare() {
mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor
rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/zlib
ln -sfT $srcdir/zlib go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/zlib
+
+ cd $srcdir/libgit2
+ patch -p1 < ../fix_libgit2_build.patch
}
build() {
diff --git a/fix_libgit2_build.patch b/fix_libgit2_build.patch
new file mode 100644
index 000000000000..bd8cb43e0c26
--- /dev/null
+++ b/fix_libgit2_build.patch
@@ -0,0 +1,39 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4783e3ef9..da34f9fe7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -327,34 +327,15 @@ IF(WIN32 OR AMIGA OR CMAKE_SYSTEM_NAME MATCHES "(Solaris|SunOS)")
+ SET(SRC_REGEX deps/regex/regex.c)
+ ENDIF()
+
+-# Optional external dependency: http-parser
+-FIND_PACKAGE(HTTP_Parser)
+-IF (HTTP_PARSER_FOUND AND HTTP_PARSER_VERSION_MAJOR EQUAL 2)
+- INCLUDE_DIRECTORIES(${HTTP_PARSER_INCLUDE_DIRS})
+- LINK_LIBRARIES(${HTTP_PARSER_LIBRARIES})
+- LIST(APPEND LIBGIT2_PC_LIBS "-lhttp_parser")
+-ELSE()
+ MESSAGE(STATUS "http-parser version 2 was not found; using bundled 3rd-party sources.")
+ INCLUDE_DIRECTORIES(deps/http-parser)
+ FILE(GLOB SRC_HTTP deps/http-parser/*.c deps/http-parser/*.h)
+-ENDIF()
+
+ # Optional external dependency: zlib
+-FIND_PACKAGE(ZLIB)
+-IF (ZLIB_FOUND)
+- INCLUDE_DIRECTORIES(${ZLIB_INCLUDE_DIRS})
+- LINK_LIBRARIES(${ZLIB_LIBRARIES})
+- IF(APPLE OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+- LIST(APPEND LIBGIT2_PC_LIBS "-lz")
+- ELSE()
+- SET(LIBGIT2_PC_REQUIRES "${LIBGIT2_PC_REQUIRES} zlib")
+- ENDIF()
+-ELSE()
+ MESSAGE(STATUS "zlib was not found; using bundled 3rd-party sources." )
+ INCLUDE_DIRECTORIES(deps/zlib)
+ ADD_DEFINITIONS(-DNO_VIZ -DSTDC -DNO_GZIP)
+ FILE(GLOB SRC_ZLIB deps/zlib/*.c deps/zlib/*.h)
+-ENDIF()
+
+ # Optional external dependency: libssh2
+ IF (USE_SSH)