summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2019-01-12 12:48:32 -0800
committerAnatol Pomozov2019-01-12 12:48:32 -0800
commit1baa5d913b15fbbf0ede78f1f3f6fb3f12863d25 (patch)
treeb2c5e7ea85a680cb2567ff0a784dd8530dd2df64
parentd6cddeb6b6e6e19857d02131833779f86df3899c (diff)
downloadaur-1baa5d913b15fbbf0ede78f1f3f6fb3f12863d25.tar.gz
updpkg
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD75
-rw-r--r--fix_libgit2_build.patch39
-rw-r--r--fix_libssh2_build.patch13
-rwxr-xr-xparse_manifest.rb38
5 files changed, 17 insertions, 171 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 031fa0db4961..5a810b3789da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Oct 28 03:46:01 UTC 2017
pkgbase = jiri-git
pkgdesc = A tool for multi-repo development similar to Android repo
- pkgver = r1336
+ pkgver = r1423
pkgrel = 1
url = https://fuchsia.googlesource.com/jiri
arch = i686
@@ -10,27 +8,8 @@ pkgbase = jiri-git
license = MIT
makedepends = git
makedepends = go-pie
- makedepends = cmake
- makedepends = ninja
- makedepends = python2
source = git+https://fuchsia.googlesource.com/jiri
- source = git+https://fuchsia.googlesource.com/third_party/git2go
- source = git+https://fuchsia.googlesource.com/third_party/boringssl#commit=438229a8d724058cb4de1af6814204f03ce734ed
- source = git+https://fuchsia.googlesource.com/third_party/curl#commit=280e8c6e371ebd0f2e0a907e016ab44d6c9549af
- source = git+https://fuchsia.googlesource.com/third_party/libssh2#commit=615210a03ecf36e1c55ffb7101d53e5c231c2f43
- source = git+https://fuchsia.googlesource.com/third_party/libgit2#commit=25a4b97b1bd0b5316deb77866756a3db772e08a2
- source = git+https://fuchsia.googlesource.com/third_party/zlib#commit=871bb1c83c0a4cc180c66ac89b14cb08675bef0d
- source = fix_libgit2_build.patch
- source = fix_libssh2_build.patch
sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = 798fbefdda5144f30e9fe6bde7ef0df01c0e9caf
- sha1sums = 011af8785b96372b73e95d3c04012ad0bb34344a
pkgname = jiri-git
diff --git a/PKGBUILD b/PKGBUILD
index 05cd7790bc34..56d8bce8db89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,16 @@
# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=jiri-git
-pkgver=r1336
+pkgver=r1423
pkgrel=1
pkgdesc='A tool for multi-repo development similar to Android repo'
arch=(i686 x86_64)
url='https://fuchsia.googlesource.com/jiri'
license=(MIT)
depends=()
-makedepends=(git go-pie cmake ninja python2)
-source=(
- git+https://fuchsia.googlesource.com/jiri
- git+https://fuchsia.googlesource.com/third_party/git2go
- git+https://fuchsia.googlesource.com/third_party/boringssl#commit=438229a8d724058cb4de1af6814204f03ce734ed
- git+https://fuchsia.googlesource.com/third_party/curl#commit=280e8c6e371ebd0f2e0a907e016ab44d6c9549af
- git+https://fuchsia.googlesource.com/third_party/libssh2#commit=615210a03ecf36e1c55ffb7101d53e5c231c2f43
- git+https://fuchsia.googlesource.com/third_party/libgit2#commit=25a4b97b1bd0b5316deb77866756a3db772e08a2
- git+https://fuchsia.googlesource.com/third_party/zlib#commit=871bb1c83c0a4cc180c66ac89b14cb08675bef0d
-
- fix_libgit2_build.patch
- fix_libssh2_build.patch
-)
-sha1sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '798fbefdda5144f30e9fe6bde7ef0df01c0e9caf'
- '011af8785b96372b73e95d3c04012ad0bb34344a')
+makedepends=(git go-pie)
+source=(git+https://fuchsia.googlesource.com/jiri)
+sha1sums=('SKIP')
pkgver() {
cd jiri
@@ -37,45 +18,21 @@ pkgver() {
}
prepare() {
- cd jiri
-
- # script sets GOPATH to fuchsia wide location, we do not have it
- sed -i 's/export GOPATH=.*//' scripts/build.sh
- mkdir -p go
-
- mkdir -p go/src/fuchsia.googlesource.com
- rm -rf go/src/fuchsia.googlesource.com/jiri
- ln -sfT $srcdir/jiri go/src/fuchsia.googlesource.com/jiri
- mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2
- rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go
- ln -sfT $srcdir/git2go go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go
- mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor
- rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/boringssl
- ln -sfT $srcdir/boringssl go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/boringssl
- mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor
- rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/curl
- ln -sfT $srcdir/curl go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/curl
- mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor
- rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/libssh2
- ln -sfT $srcdir/libssh2 go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/libssh2
- mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor
- rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/libgit2
- ln -sfT $srcdir/libgit2 go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/libgit2
- mkdir -p go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor
- rm -rf go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/zlib
- ln -sfT $srcdir/zlib go/src/fuchsia.googlesource.com/jiri/vendor/github.com/libgit2/git2go/vendor/zlib
-
- cd $srcdir/libgit2
- patch -p1 < ../fix_libgit2_build.patch
-
- cd $srcdir/libssh2
- patch -p1 < ../fix_libssh2_build.patch
+ mkdir -p gopath/src/fuchsia.googlesource.com
+ ln -rTsf jiri gopath/src/fuchsia.googlesource.com/jiri
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/fuchsia.googlesource.com/jiri
+ go get -v -d ./...
}
build() {
- cd jiri
-
- GOPATH=`pwd`/go ./scripts/build.sh
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/fuchsia.googlesource.com/jiri
+ go build -v \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ ./cmd/...
}
package() {
diff --git a/fix_libgit2_build.patch b/fix_libgit2_build.patch
deleted file mode 100644
index bd8cb43e0c26..000000000000
--- a/fix_libgit2_build.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4783e3ef9..da34f9fe7 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -327,34 +327,15 @@ IF(WIN32 OR AMIGA OR CMAKE_SYSTEM_NAME MATCHES "(Solaris|SunOS)")
- SET(SRC_REGEX deps/regex/regex.c)
- ENDIF()
-
--# Optional external dependency: http-parser
--FIND_PACKAGE(HTTP_Parser)
--IF (HTTP_PARSER_FOUND AND HTTP_PARSER_VERSION_MAJOR EQUAL 2)
-- INCLUDE_DIRECTORIES(${HTTP_PARSER_INCLUDE_DIRS})
-- LINK_LIBRARIES(${HTTP_PARSER_LIBRARIES})
-- LIST(APPEND LIBGIT2_PC_LIBS "-lhttp_parser")
--ELSE()
- MESSAGE(STATUS "http-parser version 2 was not found; using bundled 3rd-party sources.")
- INCLUDE_DIRECTORIES(deps/http-parser)
- FILE(GLOB SRC_HTTP deps/http-parser/*.c deps/http-parser/*.h)
--ENDIF()
-
- # Optional external dependency: zlib
--FIND_PACKAGE(ZLIB)
--IF (ZLIB_FOUND)
-- INCLUDE_DIRECTORIES(${ZLIB_INCLUDE_DIRS})
-- LINK_LIBRARIES(${ZLIB_LIBRARIES})
-- IF(APPLE OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
-- LIST(APPEND LIBGIT2_PC_LIBS "-lz")
-- ELSE()
-- SET(LIBGIT2_PC_REQUIRES "${LIBGIT2_PC_REQUIRES} zlib")
-- ENDIF()
--ELSE()
- MESSAGE(STATUS "zlib was not found; using bundled 3rd-party sources." )
- INCLUDE_DIRECTORIES(deps/zlib)
- ADD_DEFINITIONS(-DNO_VIZ -DSTDC -DNO_GZIP)
- FILE(GLOB SRC_ZLIB deps/zlib/*.c deps/zlib/*.h)
--ENDIF()
-
- # Optional external dependency: libssh2
- IF (USE_SSH)
diff --git a/fix_libssh2_build.patch b/fix_libssh2_build.patch
deleted file mode 100644
index e0b29b735c9e..000000000000
--- a/fix_libssh2_build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/openssl.h b/src/openssl.h
-index 6aa1219..f393c9c 100644
---- a/src/openssl.h
-+++ b/src/openssl.h
-@@ -223,7 +223,7 @@ int _libssh2_md5_init(libssh2_md5_ctx *ctx);
- #define libssh2_hmac_update(ctx, data, datalen) \
- HMAC_Update(&(ctx), data, datalen)
- #define libssh2_hmac_final(ctx, data) HMAC_Final(&(ctx), data, NULL)
--#define libssh2_hmac_cleanup(ctx) HMAC_cleanup(ctx)
-+#define libssh2_hmac_cleanup(ctx) HMAC_CTX_cleanup(ctx)
- #endif
-
- #define libssh2_crypto_init() \
diff --git a/parse_manifest.rb b/parse_manifest.rb
deleted file mode 100755
index 98fa9f1623c6..000000000000
--- a/parse_manifest.rb
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/ruby
-
-# Jiri build system uses jiri to checkout its dependencies :(
-# https://fuchsia.googlesource.com/manifest/+/refs/heads/master/jiri
-# to avoid this chicken-egg problem we parse the manifest and generate
-# the dependencies that easy to use in the PKGBUILD file
-
-require 'open-uri'
-require 'xmlsimple'
-
-deps = []
-
-doc = XmlSimple.xml_in(open('https://raw.githubusercontent.com/fuchsia-mirror/manifest/master/jiri'))
-for pr in doc['projects'][0]['project']
- name = pr['name']
- remote = pr['remote']
- rev = pr['revision']
- path = pr['path']
-
- url = "git+#{remote}"
- url += "#commit=#{rev}" if rev
-
- deps << [url, remote, path]
-end
-
-puts "Sources:"
-for d in deps
- puts " #{d[0]}"
-end
-
-puts "Prepare:"
-for d in deps
- url, remote, path = *d
-
- puts " mkdir -p #{File.dirname(path)}"
- puts " rm -rf #{path}"
- puts " ln -sfT $srcdir/#{File.basename(remote)} #{path}"
-end