summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Devlamynck2015-06-10 20:41:04 +0200
committerXavier Devlamynck2015-06-10 20:41:04 +0200
commit0e5cff220e726233d4f41a3bfb33df7ca8bd122e (patch)
treeb749dfce821ed28b931988f37d9e4d510d9a6f1e
downloadaur-0e5cff220e726233d4f41a3bfb33df7ca8bd122e.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
-rw-r--r--jitsi.desktop10
-rw-r--r--jitsi.sh17
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b47d15cd3444
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = jitsi
+ pkgdesc = An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator)
+ pkgver = 2.8.5426
+ pkgrel = 1
+ url = http://jitsi.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = apache-ant
+ makedepends = java-environment
+ depends = java-runtime
+ options = !strip
+ options = !emptydirs
+ options = zipman
+ options = !libtool
+ options = docs
+ source = http://download.jitsi.org/jitsi/src/jitsi-src-2.8.5426.zip
+ source = jitsi.desktop
+ source = jitsi.sh
+ sha256sums = e649867e186cf195c4b1bb159d7ffe0a38c4dc60659e5c55f9a74461a309f36c
+ sha256sums = 61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d
+ sha256sums = 529722efc3bae6cb8923680363a4d778ccf78db9caf20bee90a110d34181d9f5
+
+pkgname = jitsi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04696330a7d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Xavier Devlamynck <magicrhesus@ouranos.be>
+# Contributors: Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
+
+pkgname=jitsi
+pkgver=2.8.5426
+pkgrel=1
+pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator)"
+arch=('i686' 'x86_64')
+url="http://jitsi.org"
+license=('LGPL')
+depends=('java-runtime')
+makedepends=('apache-ant' 'java-environment')
+options=(!strip !emptydirs zipman !libtool docs)
+source=("http://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
+ jitsi.desktop
+ jitsi.sh)
+sha256sums=('e649867e186cf195c4b1bb159d7ffe0a38c4dc60659e5c55f9a74461a309f36c'
+ '61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d'
+ '529722efc3bae6cb8923680363a4d778ccf78db9caf20bee90a110d34181d9f5')
+
+build()
+{
+ cd "${srcdir}/${pkgname}"
+ # append the build revision to the jitsi version
+ sed -i "s/0\.build\.by\.SVN/build.${pkgver}/" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
+ . /etc/profile.d/apache-ant.sh
+ ant rebuild
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ find lib/ lib/bundle/ -maxdepth 1 -type f -exec install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/"{} \;
+# find lib/os-specific/linux/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/"{} \;
+ shopt -sq extglob
+ find lib/native/linux$(sed 's/_/-/g' <<<${CARCH/#*(i?86|x86)/})/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/native/"{} \;
+ find sc-bundles/{,os-specific/linux/} -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/sc-bundles/"{} \;
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ cd "resources/install/debian/"
+ for _file in *.{svg,xpm}; do
+ install -Dm644 "$_file" "${pkgdir}/usr/share/pixmaps/${_file}"
+ done
+}
diff --git a/jitsi.desktop b/jitsi.desktop
new file mode 100644
index 000000000000..dd4de82a6501
--- /dev/null
+++ b/jitsi.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Jitsi
+GenericName=jitsi
+Comment=VoIP and Instant Messaging client
+Icon=/usr/share/pixmaps/jitsi.svg
+Type=Application
+Categories=Network
+Exec=/usr/bin/jitsi
+Terminal=false
diff --git a/jitsi.sh b/jitsi.sh
new file mode 100644
index 000000000000..6e53cdbf569d
--- /dev/null
+++ b/jitsi.sh
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+CLIENTARGS=""
+uname -m | grep i686 && CLIENTARGS="-client -Xmx256m"
+
+SCDIR=/usr/lib/jitsi
+LIBPATH="$SCDIR/lib"
+CLASSPATH="$LIBPATH/jdic_stub.jar:$LIBPATH/jdic-all.jar:$LIBPATH/felix.jar:$LIBPATH/bcprovider.jar:$SCDIR/sc-bundles/sc-launcher.jar:$SCDIR/sc-bundles/util.jar"
+FELIX_CONFIG="$LIBPATH/felix.client.run.properties"
+LOG_CONFIG="$LIBPATH/logging.properties"
+COMMAND=("$JAVA_HOME/bin/java" $CLIENTARGS -classpath "$CLASSPATH" -Djna.library.path="$LIBPATH/native" -Dfelix.config.properties="file:$FELIX_CONFIG" -Djava.util.logging.config.file="$LOG_CONFIG" net.java.sip.communicator.launcher.SIPCommunicator)
+
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIBPATH/native"
+
+cd "$SCDIR"
+
+exec "${COMMAND[@]}" "$@"