summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2021-09-15 19:18:47 +0200
committerlsf2021-09-15 19:18:47 +0200
commitf6d29d45f9282013befffa97f9659fe233542b69 (patch)
tree50960af771e28ceecfc06fee437a598dce27c2be
parentf692b3e31f8d4bd0c0c763811a616ed85ece32f7 (diff)
downloadaur-f6d29d45f9282013befffa97f9659fe233542b69.tar.gz
v2.8.12-1; drop pipewire fix
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--pipewire_wayland.patch14
3 files changed, 5 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc7b09af8ded..53c4bfbe511a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jitsi-meet-desktop
pkgdesc = Jitsi Meet desktop application
- pkgver = 2.8.11
+ pkgver = 2.8.12
pkgrel = 1
url = https://jitsi.org/jitsi-meet/
arch = x86_64
@@ -18,12 +18,10 @@ pkgbase = jitsi-meet-desktop
conflicts = jitsi-meet-electron
replaces = jitsi-meet-electron
options = !strip
- source = jitsi-meet-desktop_2.8.11.tar.gz::https://github.com/jitsi/jitsi-meet-electron/archive/v2.8.11.tar.gz
- source = pipewire_wayland.patch
+ source = jitsi-meet-desktop_2.8.12.tar.gz::https://github.com/jitsi/jitsi-meet-electron/archive/v2.8.12.tar.gz
source = no_targets.patch
source = jitsi-meet-desktop.desktop
- sha256sums = 23140b13aa07e0d072088f721520c1454035332010ee47c0d0faf199c32dfcfd
- sha256sums = 39d54520962f8665e858748335594cca6b504884462b80d79a0d8aa6141129c4
+ sha256sums = 7c9e6b362aa00a9267d8995f094006c5f4a979de4a6c09ae2311dcf68891427b
sha256sums = ab22749aa1570cc5d6050711011f849ec3f4fa49080231f98957255fa5250e36
sha256sums = 36a30a15613d53b2a01626a5551315c6970889ce3c2688bce71e26c3333081a4
diff --git a/PKGBUILD b/PKGBUILD
index 9f1e90e075d9..c19c15ac7a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Roman Kupriyanov <mr.eshua@gmail.com>
pkgname=jitsi-meet-desktop
-pkgver=2.8.11
+pkgver=2.8.12
pkgrel=1
pkgdesc="Jitsi Meet desktop application"
arch=('x86_64' 'aarch64')
@@ -27,11 +27,9 @@ makedepends=('coreutils'
options=(!strip)
source=("${pkgname}_${pkgver}.tar.gz::https://github.com/jitsi/jitsi-meet-electron/archive/v${pkgver}.tar.gz"
- 'pipewire_wayland.patch'
'no_targets.patch'
'jitsi-meet-desktop.desktop')
-sha256sums=('23140b13aa07e0d072088f721520c1454035332010ee47c0d0faf199c32dfcfd'
- '39d54520962f8665e858748335594cca6b504884462b80d79a0d8aa6141129c4'
+sha256sums=('7c9e6b362aa00a9267d8995f094006c5f4a979de4a6c09ae2311dcf68891427b'
'ab22749aa1570cc5d6050711011f849ec3f4fa49080231f98957255fa5250e36'
'36a30a15613d53b2a01626a5551315c6970889ce3c2688bce71e26c3333081a4')
@@ -61,12 +59,6 @@ prepare() {
_electron_ver=$(cat ${_electron_dist}/version)
sed -r 's#("electron": ").*"#\1'${_electron_ver}'"#' -i package.json
- # This patch from https://github.com/jitsi/jitsi-meet-electron/commit/0e0483cbc52a9cad1fef51ed5abb846bd6445b11
- # broke jitsi-meet-electron for me on when running on sway with full wayland support via flags
- # If you you want to use that feature flag (--WebRTCPipeWireCapturer), I'd recommend putting it in
- # ~/.config/electron-flags.conf manually instead of having it applied by default
- patch -Np1 -i ${srcdir}/pipewire_wayland.patch
-
npm install
# npm audit fix
}
diff --git a/pipewire_wayland.patch b/pipewire_wayland.patch
deleted file mode 100644
index 9f22697d0b66..000000000000
--- a/pipewire_wayland.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/main.js b/main.js
-index 94d4352..a294ba4 100644
---- a/main.js
-+++ b/main.js
-@@ -37,9 +37,6 @@ app.commandLine.appendSwitch('disable-features', 'IOSurfaceCapturer');
- // Enable Opus RED field trial.
- app.commandLine.appendSwitch('force-fieldtrials', 'WebRTC-Audio-Red-For-Opus/Enabled/');
-
--// Enable optional PipeWire support.
--app.commandLine.appendSwitch('enable-features', 'WebRTCPipeWireCapturer');
--
- // Needed until robot.js is fixed: https://github.com/octalmage/robotjs/issues/580
- app.allowRendererProcessReuse = false;
-