summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcelogeek2020-07-17 11:45:30 +0200
committercelogeek2020-07-17 11:45:30 +0200
commitfb07c50b50d10db4f55561b879116232d17ccbb9 (patch)
treeb79d3ae3c18ca11a2480bf633f1e6218c797f2aa
parent7d788ef70e5d41d695b10d44bf9bff33b16b067e (diff)
downloadaur-fb07c50b50d10db4f55561b879116232d17ccbb9.tar.gz
update to 2.1+202+g5f9377b9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
-rw-r--r--config17
-rw-r--r--sip-communicator.properties21
4 files changed, 26 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ffee5f03a6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.deb
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 263e3b941ef2..9d57f3020036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgname=jitsi-videobridge
pkgname=${_pkgname}-bin
epoch=1
-pkgver=2.1+183+gdbddd169
+pkgver=2.1+202+g5f9377b9
pkgrel=1
_debname=${_pkgname}2
_debrel=1
@@ -26,12 +26,12 @@ source=("https://download.jitsi.org/stable/${_debname}_${pkgver//+/-}-${_debrel}
'tmpfiles.conf'
'config'
'sip-communicator.properties')
-sha256sums=('c2dd14437e4e655818bc1c3890b75384e5980042e8475a1142540afc04555ada'
+sha256sums=('0afce2a9c591e72a69c28665f8bf48d5e9d3a4e253e6be8737b1913f4d25b29b'
'33a8329b2b886246dee8cca07b93e1c8977191170256ea65889d7a63937c06a9'
'5b47b031d7a1dec536d3fc53e71d971b1052ea2e78e1060b404a792211363515'
'885923de1718b757826596aaec8e58025ae40ed622bad4b5f43b12ab975c86a2'
- '4d458fdac2f1a5ff761d6239076e7cfafe4812a3d4a12e754b48c828f46a1f44'
- 'be0a457c27ba99c514bbad4f2ce3494589eb242987f42246f2fe2df636538790')
+ '46f686cd8ea6bb5f1ec6055d2f16cc72db4baf9d90dea234d10e661b50924624'
+ 'cc9fbf77497bce3c9673b2d144928f11cdd0c0823940c2b60c8369a2f086b9b7')
package() {
cd "${srcdir}"
diff --git a/config b/config
index e5a51c05ba32..0a61f06f5848 100644
--- a/config
+++ b/config
@@ -1,22 +1,25 @@
# Jitsi Videobridge settings
# sets the XMPP domain (default: none)
-JVB_HOSTNAME=
+JVB_HOSTNAME=jitsi-meet.example.org
# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)
-JVB_HOST=localhost
+JVB_HOST=
# sets the port of the XMPP server (default: 5275)
JVB_PORT=5347
# sets the shared secret used to authenticate to the XMPP server
-JVB_SECRET=
+JVB_SECRET=__PASSWORD_FOR_USER_jvb@auth.jitsi-meet.example.org__
# extra options to pass to the JVB daemon
JVB_OPTS="--apis=,"
+
# adds java system props that are passed to jvb (default are for home and logging config file)
-JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi\
- -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge\
- -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi-videobridge\
- -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"
+JAVA_SYS_PROPS="\
+ -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi\
+ -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge\
+ -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi-videobridge\
+ -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties\
+"
diff --git a/sip-communicator.properties b/sip-communicator.properties
index 0c89cc5fdc25..adbcb969ac19 100644
--- a/sip-communicator.properties
+++ b/sip-communicator.properties
@@ -1,15 +1,10 @@
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
-
-# Uncomment and configure to enable XMPP client
-#org.jitsi.videobridge.ENABLE_STATISTICS=true
-#org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
-#org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
-#org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.JVB_HOSTNAME
-#org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
-#org.jitsi.videobridge.xmpp.user.shard.PASSWORD=JVB_SECRET
-#org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.JVB_HOSTNAME
-#org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=SOME_RANDOM_UUID
-
-# Uncomment to enable component (replace JVB_HOSTNAME by the value in config)
-#org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.JVB_HOSTNAME/.*
+org.jitsi.videobridge.ENABLE_STATISTICS=true
+org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
+org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
+org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.jitsi-meet.example.org
+org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
+org.jitsi.videobridge.xmpp.user.shard.PASSWORD=__PASSWORD_FOR_USER_jvb@auth.jitsi-meet.example.org__
+org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.jitsi-meet.example.org
+org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=__RANDOM_UUID__