summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2020-12-06 15:52:51 +0100
committerredtide2020-12-06 15:52:51 +0100
commitd358e7f0143ea0cc2be015616032cf9d72665935 (patch)
treef084759321d7935c7922962ecaff9f8b337fbee6
downloadaur-d358e7f0143ea0cc2be015616032cf9d72665935.tar.gz
First commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--JKnobMan.desktop6
-rw-r--r--KnobmanXdgConfig.aj69
-rw-r--r--PKGBUILD31
-rw-r--r--jknobman6
6 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..820a27092f0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = jknobman-bin
+ pkgdesc = VSTGUI - AnimationKnob Design tool
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = https://www.g200kg.com/jp/software/knobman.html
+ arch = any
+ license = custom
+ makedepends = unzip
+ makedepends = aspectj
+ depends = java-runtime
+ conflicts = jknobman
+ conflicts = jknobman-git
+ source = https://github.com/g200kg/KnobMan/raw/master/JKnobMan133-jar.zip
+ source = jknobman
+ source = JKnobMan.desktop
+ source = KnobmanXdgConfig.aj
+ sha256sums = 85acce3104f1a95bf8aa578dff640b427b114d6114e7556f4c65b2db08f3ed80
+ sha256sums = 2eb7799428f6f80be28f872213f354d5b435b0fa7794b9e3c96f5f7b2fac0048
+ sha256sums = a7baf9a105ba69c08defc818e07245461b6c3eb7b558e9280c0813d89dd9aa37
+ sha256sums = 9a6781e2db9d8fb17789bf94599048b14831fe4f64959df33a6002f17cb5127c
+
+pkgname = jknobman-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fce96511ec22
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar*
+*.zip
diff --git a/JKnobMan.desktop b/JKnobMan.desktop
new file mode 100644
index 000000000000..4f24d243c9e6
--- /dev/null
+++ b/JKnobMan.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=JKnobMan
+Exec=jknobman
+Icon=/usr/share/JKnobMan/Resource/Images/JKnobMan.png
+Categories=AudioVideo;Audio;
diff --git a/KnobmanXdgConfig.aj b/KnobmanXdgConfig.aj
new file mode 100644
index 000000000000..5982f6a1533d
--- /dev/null
+++ b/KnobmanXdgConfig.aj
@@ -0,0 +1,69 @@
+/*
+ Boost Software License - Version 1.0 - August 17th, 2003
+
+ Permission is hereby granted, free of charge, to any person or organization
+ obtaining a copy of the software and accompanying documentation covered by
+ this license (the "Software") to use, reproduce, display, distribute,
+ execute, and transmit the Software, and to prepare derivative works of the
+ Software, and to permit third-parties to whom the Software is furnished to
+ do so, all subject to the following:
+
+ The copyright notices in the Software and this entire statement, including
+ the above license grant, this restriction and the following disclaimer,
+ must be included in all copies of the Software, in whole or in part, and
+ all derivative works of the Software, unless such copies or derivative
+ works are solely in the form of machine-executable object code generated by
+ a source language processor.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
+ SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
+ FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
+ ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ DEALINGS IN THE SOFTWARE.
+*/
+/**
+ Relocate configuration files of type .ini in the XDG directory:
+ ~/.config/JKnobMan/
+ */
+
+import java.io.File;
+
+public aspect KnobmanXdgConfig {
+ Object around(): execution(String ResFilename.GetString())
+ {
+ ResFilename self = (ResFilename)thisJoinPoint.getTarget();
+ String filename = self.str;
+
+ boolean isConfig = filename.endsWith(".ini");
+ if (isConfig) {
+ File configDir = getKnobmanConfigDir();
+ configDir.mkdir();
+ File configFile = new File(configDir, filename);
+ System.err.println("Configuration file: " + configFile);
+ return configFile.toString();
+ }
+
+ return proceed();
+ }
+
+ private static File getKnobmanConfigDir()
+ {
+ return new File(getXdgConfigPath(), "JKnobMan");
+ }
+
+ private synchronized static String getXdgConfigPath()
+ {
+ String dir = cacheXdgConfigPath;
+ if (dir != null)
+ return dir;
+ dir = System.getenv("XDG_CONFIG_HOME");
+ if (dir == null)
+ dir = new File(System.getProperty("user.home"), ".config").toString();
+ cacheXdgConfigPath = dir;
+ return dir;
+ }
+
+ private static String cacheXdgConfigPath = null;
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f36b2f76100b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: redtide <redtid3@gmail.com>
+# Maintainer: Jean Pierre Cimalando <jp-dev@inbox.ru>
+
+pkgname=jknobman-bin
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="VSTGUI - AnimationKnob Design tool"
+conflicts=("jknobman" "jknobman-git")
+url="https://www.g200kg.com/jp/software/knobman.html"
+arch=('any')
+license=('custom')
+depends=('java-runtime')
+makedepends=("unzip" "aspectj")
+source=("https://github.com/g200kg/KnobMan/raw/master/JKnobMan133-jar.zip"
+ "jknobman" "JKnobMan.desktop" "KnobmanXdgConfig.aj")
+sha256sums=('85acce3104f1a95bf8aa578dff640b427b114d6114e7556f4c65b2db08f3ed80'
+ '2eb7799428f6f80be28f872213f354d5b435b0fa7794b9e3c96f5f7b2fac0048'
+ 'a7baf9a105ba69c08defc818e07245461b6c3eb7b558e9280c0813d89dd9aa37'
+ '9a6781e2db9d8fb17789bf94599048b14831fe4f64959df33a6002f17cb5127c')
+build() {
+ /opt/aspectj/bin/ajc -outjar JKnobMan-mod.jar \
+ -inpath ${srcdir}/JKnobMan.jar:/opt/aspectj/lib/aspectjrt.jar \
+ KnobmanXdgConfig.aj
+}
+package() {
+ mkdir -p "${pkgdir}/usr/share/JKnobMan"
+ unzip -q "JKnobMan133-jar.zip" -d "${pkgdir}/usr/share/JKnobMan"
+ install -Dm755 "${srcdir}/jknobman" "${pkgdir}/usr/bin/jknobman"
+ install -Dm644 "${srcdir}/JKnobMan-mod.jar" "${pkgdir}/usr/share/JKnobMan/JKnobMan.jar"
+ install -Dm644 "${srcdir}/JKnobMan.desktop" "${pkgdir}/usr/share/applications/JKnobMan.desktop"
+}
diff --git a/jknobman b/jknobman
new file mode 100644
index 000000000000..0cbfce427616
--- /dev/null
+++ b/jknobman
@@ -0,0 +1,6 @@
+#!/bin/bash
+set -e
+
+bindir=`dirname "$0"`
+sharedir="$bindir"/../share
+exec java -jar "$sharedir"/JKnobMan/JKnobMan.jar "$@"