summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-06-13 17:58:58 +0800
committertaotieren2021-06-13 17:58:58 +0800
commit970a526e37c1aa85277b077f86b0a6330aa83147 (patch)
tree1812bf20d0839714cd45d117eac2036fa216bd17
parent7a5f379c91992c9206d6e9b4cb680dfc63aa1550 (diff)
downloadaur-970a526e37c1aa85277b077f86b0a6330aa83147.tar.gz
Update dll native,builtin
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD31
2 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8119ef310eb..f4b2cb0ca8ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jlcpcassit-wine
pkgdesc = Wine 嘉立创 PC 端下单助手
pkgver = 3.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.jlc.com/portal/appDownloadsWithConfig.html
install = jlcpcassit-wine.install
arch = any
@@ -15,6 +15,7 @@ pkgbase = jlcpcassit-wine
provides = jlcpcassit-wine
conflicts = jlcpcassit-wine
conflicts = jlcpcassit
+ replaces = jlcpcassit-bin
options = !strip
source = jlcpcassit-wine_3.4.0.zip::https://download.jlc.com/jlchelper/release/3.4.0/JLCPcAssit_setup_3.4.0.zip
source = jlcpcassit-wine.install
diff --git a/PKGBUILD b/PKGBUILD
index 4511dc41beea..b1e16813f363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=jlcpcassit-wine
pkgver=3.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Wine 嘉立创 PC 端下单助手"
arch=('any')
url="https://www.jlc.com/portal/appDownloadsWithConfig.html"
license=('unknow')
provides=(${pkgname})
conflicts=(${pkgname} ${pkgname%-wine})
-# replaces=(${pkgname})
+replaces=("jlcpcassit-bin")
depends=('wine' 'winetricks' 'wqy-zenhei' 'unixodbc' 'lib32-unixodbc')
optdepends=("wine-mono-gecko-version-fix: Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine.")
# makedepends=('unarchiver')
@@ -54,6 +54,25 @@ REGEDIT4
"FontSmoothingType"=dword:00000002
"FontSmoothingGamma"=dword:00000578
"FontSmoothingOrientation"=dword:00000001
+
+[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
+"RegisteredOrganization"="${pkgname%-wine}"
+"RegisteredOwner"="${pkgname%-wine}"
+
+
+[HKEY_CURRENT_USER\Software\Wine\Dll Overrides]
+"msvcp100"="native,builtin"
+"msvcr100"="native,builtin"
+"vcruntime140"="native,builtin"
+"nim"="native,builtin"
+"nrtc"="native,builtin"
+"libcef"="native,builtin"
+"libEGL"="native,builtin"
+"libGLESv2"="native,builtin"
+"d3dcompiler_43"="native,builtin"
+"d3dcompiler_47"="native,builtin"
+"acge15"="native,builtin"
+
EOF
export WINEPREFIX="${srcdir}"/tmp/env
@@ -108,11 +127,17 @@ fi
if [ ! -f "$HOME"/.${pkgname%-wine}/regok ] ; then
touch "$HOME"/.${pkgname%-wine}/regok || exit 1
+
+# winetricks -q vcrun2010
+
+ cd "/home/taotieren"/.jlcpcassit/ && regsvr32 *.dll
+ wineserver -k
regedit "$HOME"/.${pkgname%-wine}/wine/regpatch.reg
- cd "$HOME"/.${pkgname%-wine}/ && regsvr32 *.dll
wineserver -k
fi
+# WINEDEBUG=+loaddll wine64 "$HOME"/.${pkgname%-wine}/${pkgname%-wine} "$@"
+
wine "$HOME"/.${pkgname%-wine}/${pkgname%-wine} "$@"
EOF