summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-26 09:37:38 +0800
committerzxp198210052024-01-26 09:37:38 +0800
commit2810526d1a8be1344a49ea781a82d2d4d2838928 (patch)
tree69e8735538cb45d0965368a8e00bb79b80e569f1
parentbfeb6ef33f5146cf5d575060cfb8162a699bfaba (diff)
downloadaur-2810526d1a8be1344a49ea781a82d2d4d2838928.tar.gz
update to 2.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--jlivertool.sh7
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9ef85b5ab39..f9f6489fc884 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jlivertool
pkgdesc = Bilibili 弹幕机
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/Xinrea/JLiverTool
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = jlivertool
depends = java-runtime
provides = jlivertool
conflicts = jlivertool
- source = jlivertool.git::git+https://github.com/Xinrea/JLiverTool.git#tag=v2.0.0
+ source = jlivertool.git::git+https://github.com/Xinrea/JLiverTool.git#tag=v2.1.0
source = jlivertool.sh
sha256sums = SKIP
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = jlivertool
diff --git a/PKGBUILD b/PKGBUILD
index 8494531b7505..c63c686af913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=jlivertool
_pkgname=JLiverTool
-pkgver=2.0.0
+pkgver=2.1.0
_electronversion=26
pkgrel=1
pkgdesc="Bilibili 弹幕机"
@@ -25,7 +25,7 @@ source=(
"${pkgname}.sh"
)
sha256sums=('SKIP'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
@@ -36,9 +36,12 @@ build() {
export npm_config_build_from_source=true
export npm_config_cache="${srcdir}/.npm_cache"
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
+ export npm_config_disturl=https://electronjs.org/headers
export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
+ export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
export ELECTRONVERSION="${_electronversion}"
- sed '42,53d' -i package.json
+ export HOME="${srcdir}/.electron-gyp"
+ sed '53,58d;42,47d' -i package.json
npm install
npm run build-linux
}
diff --git a/jlivertool.sh b/jlivertool.sh
index aacd8f895847..0d20cddc70ca 100644
--- a/jlivertool.sh
+++ b/jlivertool.sh
@@ -8,8 +8,7 @@ export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file