summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-12 11:40:47 +0800
committerzxp198210052023-12-12 11:40:47 +0800
commit56694f6dcbaad3932175cb3c5000b17885a69f77 (patch)
tree325e473e6f332057d13dacba3de42be1f7f2dc5b
parent096b1490dbc16ee15e28d14ba5d89548940392c1 (diff)
downloadaur-56694f6dcbaad3932175cb3c5000b17885a69f77.tar.gz
fix errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--jlivertool.sh14
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a0381b5035f..a7798b2c6e7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,6 @@ pkgbase = jlivertool
source = jlivertool-1.4.1::git+https://github.com/Xinrea/JLiverTool.git#tag=v1.4.1
source = jlivertool.sh
sha256sums = SKIP
- sha256sums = e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
pkgname = jlivertool
diff --git a/PKGBUILD b/PKGBUILD
index c6ed968ac423..3b9eabd48664 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ source=(
"${pkgname}.sh"
)
sha256sums=('SKIP'
- 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
diff --git a/jlivertool.sh b/jlivertool.sh
index e69de29bb2d1..2ec4412e5c4f 100644
--- a/jlivertool.sh
+++ b/jlivertool.sh
@@ -0,0 +1,14 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
+else
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+fi \ No newline at end of file