summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBet42020-07-22 19:10:40 +0800
committerBet42020-07-22 19:10:40 +0800
commitc6c88179364a8e06c1e833f38ec425b6bc7fcf3b (patch)
tree08c5b0f998e425885f3d38e7e3bddec9e8047b35
downloadaur-c6c88179364a8e06c1e833f38ec425b6bc7fcf3b.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1943b1aaa74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = jnitrace
+ pkgdesc = A Frida based tool that traces usage of the JNI API in Android apps
+ pkgver = 3.0.8
+ pkgrel = 1
+ url = https://github.com/chame1eon/jnitrace
+ arch = any
+ license = MIT
+ depends = python-frida
+ depends = python-hexdump
+ source = https://files.pythonhosted.org/packages/source/j/jnitrace/jnitrace-3.0.8.tar.gz
+ sha256sums = 127a54a7ef0869d7f109a507705a9e71b4fc0741610e48b67d5ca2c461106a49
+
+pkgname = jnitrace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abf21a6c91a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Bet4 <bet4it@gmail.com>
+
+pkgname=jnitrace
+pkgver=3.0.8
+pkgrel=1
+pkgdesc="A Frida based tool that traces usage of the JNI API in Android apps"
+arch=('any')
+url="https://github.com/chame1eon/jnitrace"
+license=('MIT')
+depends=('python-frida' 'python-hexdump')
+source=("https://files.pythonhosted.org/packages/source/j/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('127a54a7ef0869d7f109a507705a9e71b4fc0741610e48b67d5ca2c461106a49')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}