summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-04-25 01:43:48 -0500
committerLuis Martinez2021-04-25 01:51:43 -0500
commit34acc6a2a2eb677003456fb2d65e3a341a42dec8 (patch)
tree1f40cbc1b922fbcf66776f6d6a13b51e1b750b78
parent1cc4d5004fff920718be160581761f68b0274d42 (diff)
downloadaur-34acc6a2a2eb677003456fb2d65e3a341a42dec8.tar.gz
update to 0.17.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
2 files changed, 40 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad4ac6c9a278..39d7d7185f17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = joker
- pkgdesc = Joker, a Clojure interpreter and linter written in Go - Precompiled binary from official repository
- pkgver = 0.12.4
+ pkgdesc = A Clojure interpreter and linter written in Go
+ pkgver = 0.17.1
pkgrel = 1
url = https://github.com/candid82/joker
arch = x86_64
license = EPL
- provides = joker
- conflicts = joker
- source = https://github.com/candid82/joker/releases/download/v0.12.4/joker-0.12.4-linux-amd64.zip
- md5sums = 2bc3812c70e885eab8f8b0e9462fb6be
+ makedepends = go
+ depends = glibc
+ source = joker-0.17.1.tar.gz::https://github.com/candid82/joker/archive/refs/tags/v0.17.1.tar.gz
+ sha256sums = 58d86fbc77e8438a5149e87f07eef7c98f3692576c1bf38d1916026a4642ab7c
pkgname = joker
+
diff --git a/PKGBUILD b/PKGBUILD
index 52ea24d865ba..89bce268a44e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,44 @@
-# Maintainer: David Harrigan <dharrigan@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
pkgname=joker
-pkgver=0.12.4
+pkgver=0.17.1
pkgrel=1
-pkgdesc="Joker, a Clojure interpreter and linter written in Go - Precompiled binary from official repository"
+pkgdesc="A Clojure interpreter and linter written in Go"
arch=('x86_64')
url="https://github.com/candid82/joker"
license=('EPL')
-provides=('joker')
-conflicts=('joker')
+depends=('glibc')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('58d86fbc77e8438a5149e87f07eef7c98f3692576c1bf38d1916026a4642ab7c')
-source=("https://github.com/candid82/joker/releases/download/v${pkgver}/${pkgname}-${pkgver}-linux-amd64.zip")
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
-md5sums=('2bc3812c70e885eab8f8b0e9462fb6be')
+ cd "$pkgname-$pkgver"
+ go generate ./...
+ go vet ./...
+ go build
+}
+
+check() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname-$pkgver"
+ go test
+}
package() {
- install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "$pkgname-$pkgver"
+ install -Dvm 755 joker -t "$pkgdir/usr/bin/"
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md DEVELOPER.md LIBRARIES.md -t "$pkgdir/usr/share/doc/$pkgname/"
}