summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthynkon2021-08-16 20:34:30 +0200
committerthynkon2021-08-16 20:34:30 +0200
commit464d9fa8883d0d9f7d12791e981a96d34ae18901 (patch)
treed69b87d60ca6363e1894433d488523bf3996c356
parent9903c8ee8bc76f0f075f55883c1bfdd2d83d56e7 (diff)
downloadaur-464d9fa8883d0d9f7d12791e981a96d34ae18901.tar.gz
Update to v. 2.3.3-1
-rw-r--r--.SRCINFO9
-rw-r--r--LICENSE45
-rw-r--r--PKGBUILD8
-rw-r--r--joplin-appimage.install15
4 files changed, 58 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b6d0ce902b4..be378a8d93f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = joplin-appimage
pkgdesc = The latest stable AppImage of Joplin - a cross-platform note taking and to-do app
- pkgver = 2.2.7
+ pkgver = 2.3.3
pkgrel = 1
url = https://github.com/laurent22/joplin
+ install = joplin-appimage.install
arch = x86_64
license = MIT
depends = fuse2
options = !strip
- source = https://github.com/laurent22/joplin/releases/download/v2.2.7/Joplin-2.2.7.AppImage
- source = https://github.com/laurent22/joplin/raw/v2.2.7/LICENSE
- sha512sums = ef0967107a2f88717ab0524f14111872c2cab6feb7d72572e28637fb19664bcd485aac1b91382d7b43222066fdc0e540d416d4f2c7fd458277faad2ddbb2e1a2
+ source = https://github.com/laurent22/joplin/releases/download/v2.3.3/Joplin-2.3.3.AppImage
+ source = https://github.com/laurent22/joplin/raw/v2.3.3/LICENSE
+ sha512sums = 9d4c28afa1f11be91dd9c33926eb29b0b0baa4aa6038c2163e34505cb7ab551a125d74dbadd86afe30fbfbe330bb15955cd35f600415a4dae627616a387bcfba
sha512sums = SKIP
pkgname = joplin-appimage
diff --git a/LICENSE b/LICENSE
index 2ed9d6c1262a..c27b8c025a94 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,21 +1,40 @@
+All code in this repository is licensed under the MIT License **unless a
+directory contains a LICENSE file**, in which case that LICENSE file applies to
+the code in that sub-directory.
+
+For example, packages/fork-sax contains a ISC LICENSE file, thus all code under
+the packages/fork-sax directory is licensed under ISC.
+
+For example, packages/app-cli does NOT contain a LICENSE file, thus all code
+under that directory is licensed under the default license, which is MIT.
+
+* * *
+
+Logo and Icon License
+
+The Joplin logos and icons are copyright (c) Laurent Cozic, all rights reserved,
+and may not be used without a permission. If you would like to use the logos or
+icons please contact the author in order to get a permission.
+
+* * *
+
MIT License
-Copyright (c) 2016-2020 Laurent Cozic
+Copyright (c) 2016-2021 Laurent Cozic
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 9521132a150a..662bd903b3f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: thynkon <thynkon at protonmail dot com>
pkgname=joplin-appimage
-pkgver=2.2.7
+pkgver=2.3.3
pkgrel=1
pkgdesc="The latest stable AppImage of Joplin - a cross-platform note taking and to-do app"
arch=('x86_64')
@@ -15,9 +15,10 @@ source=(
${url}/raw/v${pkgver}/LICENSE
)
sha512sums=(
- ef0967107a2f88717ab0524f14111872c2cab6feb7d72572e28637fb19664bcd485aac1b91382d7b43222066fdc0e540d416d4f2c7fd458277faad2ddbb2e1a2
+ 9d4c28afa1f11be91dd9c33926eb29b0b0baa4aa6038c2163e34505cb7ab551a125d74dbadd86afe30fbfbe330bb15955cd35f600415a4dae627616a387bcfba
SKIP
)
+install="${pkgname}.install"
package() {
chmod +x $_filename
@@ -38,6 +39,9 @@ package() {
install -Dm644 "squashfs-root/@joplinapp-desktop.desktop" "$pkgdir/usr/share/applications/joplin.desktop"
install -Dm755 "$_filename" "$pkgdir$INSTALL_PATH"
+ # install license file
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/joplin-appimage/LICENSE"
+
# disable AppImage integration prompt
# https://github.com/electron-userland/electron-builder/issues/1962
install -dm755 "$pkgdir/usr/share/appimagekit"
diff --git a/joplin-appimage.install b/joplin-appimage.install
new file mode 100644
index 000000000000..e3543fdd1b49
--- /dev/null
+++ b/joplin-appimage.install
@@ -0,0 +1,15 @@
+post_upgrade() {
+ # only show warning if upgrading to v2.3.3-1
+ vercmp "$1" "2.3.3-1" > /dev/null 2>&1
+ [[ $? -lt 0 ]] && exit 0
+
+ cat << EOF
+
+ CAUTION: This release will ask you to upgrade your sync target,
+ whether it's Dropbox, OneDrive, Joplin Cloud, etc.
+ Once it is done, only apps version 2.3+ will be able to
+ sync with it, so make sure you are ready to upgrade all your
+ apps before installing this version.
+
+EOF
+}