summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthynkon2022-01-08 19:49:31 +0100
committerthynkon2022-01-08 19:49:31 +0100
commitc8acbb7ac1bd3be961a2b126f91600269f8592fe (patch)
treea1467acbc5542e648c462ce766e75e005fca4db2
parent3ff222a99980744165fecf9d44b1d725f3108e55 (diff)
downloadaur-c8acbb7ac1bd3be961a2b126f91600269f8592fe.tar.gz
Disable AppimageLauncher integration prompt
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a5d86a971a7..b40fa8485c4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=joplin-appimage
pkgver=2.6.10
-pkgrel=2
+pkgrel=3
pkgdesc="The latest stable AppImage of Joplin - a cross-platform note taking and to-do app"
arch=('x86_64')
url="https://github.com/laurent22/joplin"
@@ -19,6 +19,9 @@ sha512sums=(
05cecb22db1addf36ec54b08f8891998b59c5c15d62fec73067b371cad298c7916954175f85941b195b6e4a19cdb7e197682ae9e8653e58cb362a0af8e50d872
SKIP
)
+_squashfs_desktop_file="@joplinapp-desktop.desktop"
+_desktop_file="/usr/share/applications/joplin.desktop"
+_no_desktop_integration_file="/usr/share/appimagekit/no_desktopintegration"
package() {
chmod +x $_filename
@@ -36,7 +39,10 @@ package() {
find "$pkgdir/usr/share/icons" -type f -name "@joplinapp-desktop.png" -exec chmod 644 {} \;
# install .desktop file and image file
- install -Dm644 "squashfs-root/@joplinapp-desktop.desktop" "$pkgdir/usr/share/applications/joplin.desktop"
+ # disable AppimageLauncher integration prompt
+ # https://github.com/TheAssassin/AppImageLauncher/issues/78#issuecomment-466390939
+ sed -i -E "s|Exec=/opt/appimages/Joplin.AppImage|Exec=APPIMAGELAUNCHER_DISABLE=1 /opt/appimages/Joplin.AppImage|" "squashfs-root/${_squashfs_desktop_file}"
+ install -Dm644 "squashfs-root/${_squashfs_desktop_file}" "${pkgdir}/${_desktop_file}"
install -Dm755 "$_filename" "$pkgdir$INSTALL_PATH"
# install license file
@@ -45,6 +51,6 @@ package() {
# disable AppImage integration prompt
# https://github.com/electron-userland/electron-builder/issues/1962
install -dm755 "$pkgdir/usr/share/appimagekit"
- touch "$pkgdir/usr/share/appimagekit/no_desktopintegration"
- chmod 644 "$pkgdir/usr/share/appimagekit/no_desktopintegration"
+ touch "${pkgdir}/${_no_desktop_integration_file}"
+ chmod 644 "${pkgdir}/${_no_desktop_integration_file}"
}