summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Flynn2021-01-16 02:56:56 -0500
committerSeth Flynn2021-01-16 03:00:55 -0500
commitd4d0d5856bba0ca64c082790e28f8131aa17ee36 (patch)
treea4696624d0a5f01345c05dccfddb45be2e08d678
downloadaur-d4d0d5856bba0ca64c082790e28f8131aa17ee36.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66b595de4e54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = joshuto
+ pkgdesc = ranger-like terminal file manager written in Rust
+ pkgver = 0.8.5
+ pkgrel = 1
+ url = https://github.com/kamiyaa/joshuto
+ arch = any
+ license = LGPL3
+ makedepends = git
+ makedepends = cargo
+ depends = file
+ depends = xdg-utils
+ provides = joshuto
+ conflicts = joshuto
+ source = https://github.com/kamiyaa/joshuto/archive/0.8.5.tar.gz
+ md5sums = 451bce32cde13b959ae545635c8c8f88
+
+pkgname = joshuto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd15237c2525
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Seth Flynn <g3tchoo@protonmail.com>
+
+pkgname=joshuto
+_pkgname=joshuto
+pkgver=0.8.5
+pkgrel=1
+pkgdesc="ranger-like terminal file manager written in Rust"
+arch=("any")
+url="https://github.com/kamiyaa/joshuto"
+license=("LGPL3")
+depends=("file" "xdg-utils")
+makedepends=("git" "cargo")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("https://github.com/kamiyaa/joshuto/archive/0.8.5.tar.gz")
+md5sums=("451bce32cde13b959ae545635c8c8f88")
+
+# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=loop
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ if command -v rustup > /dev/null 2>&1; then
+ RUSTFLAGS="-C target-cpu=native" rustup run stable \
+ cargo build --release
+ elif rustc --version | grep -q nightly; then
+ RUSTFLAGS="-C target-cpu=native" \
+ cargo build --release
+ else
+ cargo build --release
+ fi
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}-${pkgver}/target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}