summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Torres2023-11-14 15:12:59 +0000
committerRalph Torres2023-11-14 15:12:59 +0000
commit840932fdbf401f506259ada1ff6cfa655a81b9b1 (patch)
tree84b33c7b6849a8c68d950978916cad1a7640b162
parent941db9fa36c3168439b31f361f3e1cdb2d0ae5e3 (diff)
downloadaur-840932fdbf401f506259ada1ff6cfa655a81b9b1.tar.gz
update info, refactor
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD25
3 files changed, 14 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3871ce65f919..d28b92e8d4f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = otf-jost
- pkgdesc = An original font created by indestructible type*. It is inspired by the designs of Paul Renner.
+ pkgdesc = A sans-serif font by indestructible type* inspired by 1920s German sans-serifs
pkgver = 3.5
pkgrel = 1
- url = http://indestructible-type.github.io/Jost.html
+ url = https://indestructibletype.com/Jost
arch = any
- license = custom
- conflicts = otf-renner
- replaces = otf-renner
+ license = OFL
source = Jost-3.5.zip::https://github.com/indestructible-type/Jost/releases/download/3.5/Jost.zip
sha256sums = 1030acfb33af22e9bbd2217706c76da87a94c41c58a8ec6d61e785696b1469d9
pkgname = otf-jost
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f41e3ffde905..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-pkg/
-src/
-*.pkg.tar.*
-*.pkg.tar
-*.src.tar.*
-Jost-*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 728f3eeaa896..719a7ce105a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
-# Maintainer: H. Rosendahl <h [at] ro [dot] sendahl [dot] de>
+# Maintainer: Ralph Torres <mail at ralphptorr dot es>
+# Contributor: H. Rosendahl <h at ro dot sendahl dot de>
-pkgname='otf-jost'
+pkgname=otf-jost
pkgver=3.5
pkgrel=1
-replaces=('otf-renner')
-conflicts=('otf-renner')
-pkgdesc="An original font created by indestructible type*. It is inspired by the designs of Paul Renner."
-url="http://indestructible-type.github.io/Jost.html"
+pkgdesc='A sans-serif font by indestructible type* inspired by 1920s German sans-serifs'
arch=(any)
-license=(custom)
-source=("Jost-${pkgver}.zip::https://github.com/indestructible-type/Jost/releases/download/${pkgver}/Jost.zip")
+url=https://indestructibletype.com/Jost
+license=(OFL)
-sha256sums=('1030acfb33af22e9bbd2217706c76da87a94c41c58a8ec6d61e785696b1469d9')
+source=(Jost-${pkgver}.zip::https://github.com/indestructible-type/Jost/releases/download/$pkgver/Jost.zip)
+sha256sums=(1030acfb33af22e9bbd2217706c76da87a94c41c58a8ec6d61e785696b1469d9)
package() {
- install -d "${pkgdir}/usr/share/fonts/jost"
- install -t "${pkgdir}/usr/share/fonts/jost" -m644 "${srcdir}/Jost-master/fonts/otf/"*.otf
- install -Dm644 "${srcdir}/Jost-master/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir"/Jost-master
+ install -Dm644 -t "$pkgdir"/usr/share/fonts/jost fonts/otf/*.otf
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE.md
}
-
-# vim:set ts=2 sw=2 et: