summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrik Karlsson2017-01-15 17:04:48 +0100
committerPatrik Karlsson2017-01-15 17:04:48 +0100
commitf8732e285d3b1109d8cfa4bc2a80ab81d1785f38 (patch)
tree78f76c4561a9664dc6393b956c63cb73e822f2c9
downloadaur-f8732e285d3b1109d8cfa4bc2a80ab81d1785f38.tar.gz
Add jotasync to AUR
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD50
-rwxr-xr-xjotaclient.sh10
-rwxr-xr-xjotaserver.sh10
-rw-r--r--jotasync.desktop8
-rwxr-xr-xjotasync.sh10
7 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d36f0e817d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = jotasync
+ pkgdesc = rsync GUI with integrated scheduler
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = http://jotasync.trixon.se/
+ arch = any
+ license = Apache
+ depends = java-runtime=8
+ source = http://jotasync.trixon.se/files/jotasync-0.2.8-bin.zip
+ source = jotaclient.sh
+ source = jotaserver.sh
+ source = jotasync.sh
+ source = jotasync.desktop
+ sha256sums = 905e34af3c3d5f5468c3c83b35d8edd784f20421f0d3678ea59a017742b7fbf9
+ sha256sums = fa3eb8adf913d5e4a72087dd99e826dedf38792ce229499c70f329a651f08f9c
+ sha256sums = a81db2e919a697669a58a119a6bcf11570422abb6f67b0f381a4b65f5246b6af
+ sha256sums = 1bbbe11c32dba035dce9cd8737a9cc333a6559842d2721abcd5e5614b343c705
+ sha256sums = 7a7974ee27108b9adb1496ce261f2b023067fbb2902e97d4f62ceb12c73271c7
+
+pkgname = jotasync
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..241e560df690
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffe754c42346
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Patrik Karlsson <pata.karlsson@gmail.com>
+
+pkgname=jotasync
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="rsync GUI with integrated scheduler"
+arch=('any')
+url="http://jotasync.trixon.se/"
+license=('Apache')
+depends=('java-runtime=8')
+source=(
+ "http://jotasync.trixon.se/files/$pkgname-$pkgver-bin.zip"
+ 'jotaclient.sh'
+ 'jotaserver.sh'
+ 'jotasync.sh'
+ 'jotasync.desktop'
+)
+sha256sums=(
+ '905e34af3c3d5f5468c3c83b35d8edd784f20421f0d3678ea59a017742b7fbf9'
+ 'fa3eb8adf913d5e4a72087dd99e826dedf38792ce229499c70f329a651f08f9c'
+ 'a81db2e919a697669a58a119a6bcf11570422abb6f67b0f381a4b65f5246b6af'
+ '1bbbe11c32dba035dce9cd8737a9cc333a6559842d2721abcd5e5614b343c705'
+ '7a7974ee27108b9adb1496ce261f2b023067fbb2902e97d4f62ceb12c73271c7'
+)
+
+package() {
+ pushd "$srcdir/$pkgname-$pkgver"
+
+ # jars
+ install -d "$pkgdir/usr/share/java/jotasync"
+ find -name '*.jar' -execdir install -m644 {} "$pkgdir/usr/share/java/jotasync" \;
+
+ # icon
+ install -d "$pkgdir/usr/share/icons/hicolor/256x256/apps"
+ install -m644 jotasync.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/jotasync.png"
+
+ popd
+
+ # launchers
+ install -Dm755 "$srcdir/jotasync.sh" "$pkgdir/usr/bin/jotasync"
+ install -Dm755 "$srcdir/jotaclient.sh" "$pkgdir/usr/bin/jotaclient"
+ install -Dm755 "$srcdir/jotaserver.sh" "$pkgdir/usr/bin/jotaserver"
+
+ # .desktop
+ install -d "$pkgdir/usr/share/applications"
+ install -m644 "$srcdir/jotasync.desktop" "$pkgdir/usr/share/applications"
+
+ # remove version from filename
+ mv "$pkgdir/usr/share/java/jotasync/jotasync-${pkgver}.jar" "$pkgdir/usr/share/java/jotasync/jotasync.jar"
+}
diff --git a/jotaclient.sh b/jotaclient.sh
new file mode 100755
index 000000000000..68a34cfb4986
--- /dev/null
+++ b/jotaclient.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if ! /usr/bin/java -version 2>&1 | grep 'version "1.8' >/dev/null
+then
+ echo "jotasync requires Java 8" >&2
+ exit 1
+fi
+
+#unset JAVA_TOOL_OPTIONS
+exec /usr/bin/java -cp '/usr/share/java/jotasync/jotasync.jar' Client "$@"
+
diff --git a/jotaserver.sh b/jotaserver.sh
new file mode 100755
index 000000000000..3d73aeabb833
--- /dev/null
+++ b/jotaserver.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if ! /usr/bin/java -version 2>&1 | grep 'version "1.8' >/dev/null
+then
+ echo "jotasync requires Java 8" >&2
+ exit 1
+fi
+
+#unset JAVA_TOOL_OPTIONS
+exec /usr/bin/java -cp '/usr/share/java/jotasync/jotasync.jar' Server "$@"
+
diff --git a/jotasync.desktop b/jotasync.desktop
new file mode 100644
index 000000000000..44cc1236580b
--- /dev/null
+++ b/jotasync.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=jotasync
+Exec=/usr/bin/jotasync
+Icon=jotasync
+Categories=System;
+Keywords=sync;rsync;backup
diff --git a/jotasync.sh b/jotasync.sh
new file mode 100755
index 000000000000..10c19ac2d27c
--- /dev/null
+++ b/jotasync.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if ! /usr/bin/java -version 2>&1 | grep 'version "1.8' >/dev/null
+then
+ echo "jotasync requires Java 8" >&2
+ exit 1
+fi
+
+#unset JAVA_TOOL_OPTIONS
+exec /usr/bin/java -jar '/usr/share/java/jotasync/jotasync.jar' "$@"
+