summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Nylén2018-01-13 21:38:23 +0100
committerJoakim Nylén2018-01-13 21:38:23 +0100
commitc15d36cf939f8f2920c5a7dcb2f6cfb8ed300858 (patch)
tree6f05a9f46c4b0681a09dc6c1c4f8fb3c259ef40e
parent904d18246529c2ac50117a237f81638d521bbb1a (diff)
downloadaur-c15d36cf939f8f2920c5a7dcb2f6cfb8ed300858.tar.gz
Move to git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09448bab244c..2f6a14b8d7d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
-# Generated by mksrcinfo v8
-# Mon Sep 4 08:18:49 UTC 2017
-pkgbase = jottalib
+pkgbase = jottalib-git
pkgdesc = A library to access files stored at jottacloud.com
pkgver = 0.5.1
pkgrel = 2
- url = https://github.com/havardgulldahl/jottalib
+ url = https://github.com/Fjodor42/jottalib
arch = any
license = GPL3
+ depends = python2
depends = python2-requests
depends = python2-requests-toolbelt
depends = python2-certifi
depends = python2-dateutil
- depends = python2-humanize
depends = python2-six
depends = python2-lxml
depends = python2-xattr
depends = python2-chardet
- source = jottalib-0.5.1.tar.gz::https://github.com/havardgulldahl/jottalib/archive/v0.5.1.tar.gz
- sha256sums = 607e5270c15e593e0df494493d371d996053d45cfc2fe44a09020719fe5feaa3
+ depends = python2-clint
+ depends = python2-fusepy
+ depends = python2-watchdog
+ depends = python2-humanize
+ provides = jottalib
+ conflicts = jottalib
+ source = git+https://github.com/Fjodor42/jottalib.git
+ sha256sums = SKIP
-pkgname = jottalib
+pkgname = jottalib-git
diff --git a/PKGBUILD b/PKGBUILD
index 7d6cfec20ea7..54fffe3e9b5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
# Maintainer: Morten Linderud <morten@linderud.pw>
-pkgname=jottalib
+pkgname=jottalib-git
pkgver=0.5.1
pkgrel=2
pkgdesc="A library to access files stored at jottacloud.com"
arch=("any")
-url="https://github.com/havardgulldahl/jottalib"
+url="https://github.com/Fjodor42/jottalib"
license=('GPL3')
-depends=('python2-requests'
+depends=('python2'
+ 'python2-requests'
'python2-requests-toolbelt'
'python2-certifi'
'python2-dateutil'
- 'python2-humanize'
'python2-six'
'python2-lxml'
'python2-xattr'
- 'python2-chardet')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/havardgulldahl/jottalib/archive/v0.5.1.tar.gz")
-sha256sums=('607e5270c15e593e0df494493d371d996053d45cfc2fe44a09020719fe5feaa3')
-
-build(){
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py build
-}
+ 'python2-chardet'
+ 'python2-clint'
+ 'python2-fusepy'
+ 'python2-watchdog'
+ 'python2-humanize')
+provides=("jottalib")
+conflicts=("jottalib")
+source=('git+https://github.com/Fjodor42/jottalib.git')
+sha256sums=('SKIP')
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/jottalib"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et:
+#