summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2016-11-25 14:25:40 +0100
committerMorten Linderud2016-11-25 14:25:40 +0100
commitf487a06bb71967471464c496a4b66e527d0547ed (patch)
treec1c1c2554d8696fe7539a64a6b30386ed0bcbe1d
downloadaur-f487a06bb71967471464c496a4b66e527d0547ed.tar.gz
Added jottalib
Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9047392902c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Nov 25 13:25:31 UTC 2016
+pkgbase = jottalib
+ pkgdesc = A library to access files stored at jottacloud.com
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/havardgulldahl/jottalib
+ arch = any
+ license = GPL3
+ depends = python2-requests
+ depends = python2-requests-toolbelt
+ depends = python2-certifi
+ depends = python2-dateutil
+ depends = python2-humanize
+ depends = python2-six
+ depends = python2-chardet
+ source = jottalib.tar.gz::https://github.com/havardgulldahl/jottalib/archive/v0.5.1.tar.gz
+ sha256sums = 607e5270c15e593e0df494493d371d996053d45cfc2fe44a09020719fe5feaa3
+
+pkgname = jottalib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5276b788fd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Morten Linderud <morten@linderud.pw>
+
+pkgname=jottalib
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="A library to access files stored at jottacloud.com"
+arch=("any")
+url="https://github.com/havardgulldahl/jottalib"
+license=('GPL3')
+depends=('python2-requests'
+ 'python2-requests-toolbelt'
+ 'python2-certifi'
+ 'python2-dateutil'
+ 'python2-humanize'
+ 'python2-six'
+ 'python2-chardet')
+source=("$pkgname.tar.gz::https://github.com/havardgulldahl/jottalib/archive/v0.5.1.tar.gz")
+sha256sums=('607e5270c15e593e0df494493d371d996053d45cfc2fe44a09020719fe5feaa3')
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: