summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:40:36 +0200
committerChristian Hesse2015-06-28 21:40:36 +0200
commit9f5382b02a31286b2255f010baaf433d81a03b1d (patch)
treede3d8cb9e2891bd12eac354a2df6f7c1c29e3a2d
downloadaur-9f5382b02a31286b2255f010baaf433d81a03b1d.tar.gz
initial import of journal-notify-git 0.0.8.r7.gd187bd3-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db84bb03ef25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = journal-notify-git
+ pkgdesc = Notify about journal log entries - git checkout
+ pkgver = 0.0.8.r7.gd187bd3
+ pkgrel = 1
+ url = https://github.com/eworm-de/journal-notify
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = markdown
+ depends = libnotify
+ depends = systemd
+ depends = gnome-icon-theme
+ provides = journal-notify
+ conflicts = journal-notify
+ source = git://github.com/eworm-de/journal-notify.git
+ sha256sums = SKIP
+
+pkgname = journal-notify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a88862e8690
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=journal-notify-git
+pkgver=0.0.8.r7.gd187bd3
+pkgrel=1
+pkgdesc="Notify about journal log entries - git checkout"
+arch=('i686' 'x86_64')
+url='https://github.com/eworm-de/journal-notify'
+depends=('libnotify' 'systemd' 'gnome-icon-theme')
+makedepends=('git' 'markdown')
+provides=('journal-notify')
+conflicts=('journal-notify')
+license=('GPL')
+source=('git://github.com/eworm-de/journal-notify.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd journal-notify/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd journal-notify/
+
+ make
+}
+
+package() {
+ cd journal-notify/
+
+ make DESTDIR="${pkgdir}" install
+}
+