summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Müller2022-09-21 16:32:19 +0200
committerThorsten Müller2022-09-21 16:32:19 +0200
commit1a37669ba47c26a856dbbd1506e1c5f0df361b52 (patch)
tree9d879cca39a79535f52d5b0163232f47e6163cb2
downloadaur-1a37669ba47c26a856dbbd1506e1c5f0df361b52.tar.gz
journalbeat-oss binary package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--journalbeat-oss.service16
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a5120e82f7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = journalbeat-oss-bin
+ pkgdesc = Data shippers for Elasticsearch
+ pkgver = 7.15.2
+ pkgrel = 1
+ url = https://www.elastic.co/products/beats
+ arch = x86_64
+ license = Apache
+ depends = glibc
+ conflicts = journalbeat-oss
+ backup = etc/journalbeat-oss/journalbeat.yml,
+ backup = etc/journalbeat-oss/fields.yml
+ source = https://artifacts.elastic.co/downloads/beats/journalbeat/journalbeat-oss-7.15.2-linux-x86_64.tar.gz
+ source = journalbeat-oss.service
+ sha512sums = f2d4e0588736a606cb09cb17089d7f4b761e78763e7be41b9b0f66bd71ac8d0cd7713c654f14ce15db22b532913ea8b2fd4125e3fd3019602d87a4cbdb534fea
+ sha512sums = 977a8209341891902a3edaedcab4370ab87260f88031c404dfbae7633d9b11673fa2719f81acc716cea6028a670c484092f579e560e2ba621e74682cf08efa2f
+
+pkgname = journalbeat-oss-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c360713f2d3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thorsten Müller
+
+pkgname=journalbeat-oss-bin
+pkgver=7.15.2
+pkgrel=1
+pkgdesc='Data shippers for Elasticsearch'
+arch=('x86_64')
+url='https://www.elastic.co/products/beats'
+license=('Apache')
+depends=('glibc')
+conflicts=(journalbeat-oss)
+source=("https://artifacts.elastic.co/downloads/beats/journalbeat/journalbeat-oss-${pkgver}-linux-x86_64.tar.gz"
+ "journalbeat-oss.service")
+sha512sums=('f2d4e0588736a606cb09cb17089d7f4b761e78763e7be41b9b0f66bd71ac8d0cd7713c654f14ce15db22b532913ea8b2fd4125e3fd3019602d87a4cbdb534fea'
+ '977a8209341891902a3edaedcab4370ab87260f88031c404dfbae7633d9b11673fa2719f81acc716cea6028a670c484092f579e560e2ba621e74682cf08efa2f')
+backup=('etc/journalbeat-oss/journalbeat.yml', 'etc/journalbeat-oss/fields.yml')
+srcpath="journalbeat-${pkgver}-linux-x86_64"
+
+package() {
+ install -Dm755 "${srcdir}/${srcpath}/journalbeat" "${pkgdir}/usr/bin/journalbeat"
+ install -Dm644 "${srcdir}/${srcpath}/journalbeat.yml" "${pkgdir}/etc/journalbeat-oss/journalbeat.yml"
+ install -Dm644 "${srcdir}/${srcpath}/journalbeat.reference.yml" "${pkgdir}/etc/journalbeat-oss/journalbeat.reference.yml"
+ install -Dm644 "${srcdir}/${srcpath}/fields.yml" "${pkgdir}/etc/journalbeat-oss/fields.yml"
+ install -Dm644 "journalbeat-oss.service" "${pkgdir}/usr/lib/systemd/system/journalbeat-oss.service"
+}
diff --git a/journalbeat-oss.service b/journalbeat-oss.service
new file mode 100644
index 000000000000..554896513628
--- /dev/null
+++ b/journalbeat-oss.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Journalbeat OSS ships systemd journal entries to Logstash or directly to Elasticsearch OSS or OpenSearch.
+Documentation=https://www.elastic.co/guide/en/beats/journalbeat/7.12/index.html
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+
+Environment="BEAT_LOG_OPTS=-e"
+Environment="BEAT_CONFIG_OPTS=-c /etc/journalbeat-oss/journalbeat.yml"
+Environment="BEAT_PATH_OPTS=-path.home /usr/share/journalbeat-oss -path.config /etc/journalbeat-oss -path.data /var/lib/journalbeat-oss -path.logs /var/log/journalbeat-oss"
+ExecStart=/usr/bin/journalbeat-oss $BEAT_LOG_OPTS $BEAT_CONFIG_OPTS $BEAT_PATH_OPTS
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target