summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXi Chen2022-08-27 20:25:51 +0200
committerXi Chen2022-08-27 20:25:51 +0200
commit0facb1e47786a796b5d4f0ab14267ab111a149ee (patch)
tree6f372b7830e3536f74a25261e68944f57b2695fa
parent9ebf124c7098456c5067dacc23f28afe08ca32b1 (diff)
downloadaur-0facb1e47786a796b5d4f0ab14267ab111a149ee.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd57df13278b..3e194d7c3d4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = journalctl-desktop-notification-git
pkgdesc = The notification notifies on the desktop when any error message appeared in Journalctl log.
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
- url = https://gitlab.com/Zesko/journalctl-desktop-notification.git
+ url = https://gitlab.com/Zesko/journalctl-desktop-notification
arch = any
license = GPL3
makedepends = git
- makedepends = dunst
- makedepends = systemd
+ depends = dunst
+ depends = systemd
+ provides = journalctl-desktop-notification
+ conflicts = journalctl-desktop-notification
+ backup = etc/journalctl-desktop-notification.conf
source = git+https://gitlab.com/Zesko/journalctl-desktop-notification.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f4fe73dd542c..9435f77fec73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
-_pkgname=journalctl-desktop-notification
-pkgname="${_pkgname}-git"
-pkgver=1.0.0
+# Maintainer: Zesko
+pkgname=journalctl-desktop-notification-git
+pkgver=1.0.1
pkgrel=1
pkgdesc="The notification notifies on the desktop when any error message appeared in Journalctl log."
-arch=("any")
-url="https://gitlab.com/Zesko/${_pkgname}.git"
-license=("GPL3")
-makedepends=('git' 'dunst' 'systemd')
-source=(git+${url})
-sha256sums=("SKIP")
+arch=('any')
+url="https://gitlab.com/Zesko/journalctl-desktop-notification"
+license=('GPL3')
+depends=('dunst' 'systemd')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=("etc/${pkgname%-git}.conf")
+source=('git+https://gitlab.com/Zesko/journalctl-desktop-notification.git')
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- cd "$srcdir/$_pkgname"
- cp -vr usr "$pkgdir"
- cp -vr etc "$pkgdir"
+ cd "$srcdir/${pkgname%-git}"
+ cp -vr usr etc "$pkgdir"
}