summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbasigur2018-10-16 14:37:05 +0500
committerbasigur2018-10-16 14:37:05 +0500
commit2ba2c6d4acf3329453bfd166e34a7a01e28d24c0 (patch)
tree6aed9b6276259822b704915d66269c323cc2e794
downloadaur-2ba2c6d4acf3329453bfd166e34a7a01e28d24c0.tar.gz
joxi-lib
-rw-r--r--.SRCINFO42
-rwxr-xr-xPKGBUILD46
-rw-r--r--joxi.desktop13
-rw-r--r--joxi.sh6
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70144247924e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+# Generated by makepkg 5.1.1
+# Tue Oct 16 01:14:03 UTC 2018
+pkgbase = joxi-lib
+ pkgdesc = Free tool for screen capture
+ pkgver = 3.0.9
+ pkgrel = 5
+ url = http://joxi.ru
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = qt5-declarative
+ depends = qt5-x11extras
+ depends = qt5-base
+ depends = qt5-script
+ depends = qt5-xmlpatterns
+ depends = qt5-multimedia
+ depends = qt5-quick1
+ depends = libgl
+ depends = libx11
+ depends = libstdc++5
+ depends = libxdamage
+ depends = glib2
+ depends = gtk2
+ depends = libmcrypt
+ depends = libcurl-compat
+ depends = libappindicator-gtk2
+ conflicts = joxi
+ conflicts = joxi-bin
+ conflicts = joxi-git
+ replaces = joxi-lib
+ replaces = joxi
+ replaces = joxi-bin
+ replaces = joxi-git
+ source = http://dl.joxi.ru/linux/joxi-net_x86_64-fr.rpm
+ source = joxi.desktop
+ source = joxi.sh
+ sha512sums = 89a545cea55b1b9afcd1dddd6fa82bf08188939e1fec97e7192b2fe1d4aa875112edd22848d9d22192f05bfe7e2db47af7c73c3e5ffb7cee81c2e625b88fd849
+ sha512sums = b8f5abad72e29e3618f2cf3cefc0ace3b59d35277f3f02bd2a15bf170bfc165d7344897abbe4d79e073931301b73c49e9a2860b0911acef89c9f875ac36eeb0b
+ sha512sums = ca925c7edaaae37c88be3705ac60ba8a492080b54076e1b25fa3fa3aedf00fa0cc704df87cd6ae901812c464f49dbdc547eab0243635929867f3de562b67a5fa
+
+pkgname = joxi-lib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..d9ef0d38a8cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: basigur
+
+pkgname=joxi-lib
+_pkgname=joxi
+pkgver=3.0.9
+pkgrel=5
+pkgdesc="Free tool for screen capture"
+arch=('i686' 'x86_64')
+url="http://joxi.ru"
+license=('custom')
+depends=('qt5-declarative' 'qt5-x11extras' 'qt5-base' 'qt5-script' 'qt5-xmlpatterns' 'qt5-multimedia' 'qt5-quick1' 'libgl' 'libx11' 'libstdc++5' 'libxdamage' 'glib2' 'gtk2' 'libmcrypt' 'libcurl-compat' 'libappindicator-gtk2')
+replaces=('joxi-lib' 'joxi' 'joxi-bin' 'joxi-git')
+conflicts=('joxi' 'joxi-bin' 'joxi-git')
+
+
+if [ "${CARCH}" = 'x86_64' ]; then
+ ARCH='x86_64'
+ sha512sums=(
+ '89a545cea55b1b9afcd1dddd6fa82bf08188939e1fec97e7192b2fe1d4aa875112edd22848d9d22192f05bfe7e2db47af7c73c3e5ffb7cee81c2e625b88fd849'
+ 'b8f5abad72e29e3618f2cf3cefc0ace3b59d35277f3f02bd2a15bf170bfc165d7344897abbe4d79e073931301b73c49e9a2860b0911acef89c9f875ac36eeb0b'
+ 'ca925c7edaaae37c88be3705ac60ba8a492080b54076e1b25fa3fa3aedf00fa0cc704df87cd6ae901812c464f49dbdc547eab0243635929867f3de562b67a5fa'
+ )
+
+elif [ "${CARCH}" = 'i686' ]; then
+ ARCH='i686'
+ sha512sums=(
+ 'b9ef3cacf8f65f7a45a26d5067f4d6d5a56716769fb9a100fd4770b045f47b8accb9367146969584b25485e69d45d044e7eda8c4e416bf8b8fd068e9b778eb31'
+ 'b8f5abad72e29e3618f2cf3cefc0ace3b59d35277f3f02bd2a15bf170bfc165d7344897abbe4d79e073931301b73c49e9a2860b0911acef89c9f875ac36eeb0b'
+ 'ca925c7edaaae37c88be3705ac60ba8a492080b54076e1b25fa3fa3aedf00fa0cc704df87cd6ae901812c464f49dbdc547eab0243635929867f3de562b67a5fa'
+ )
+fi
+
+source=("http://dl.${_pkgname}.ru/linux/${_pkgname}-net_${ARCH}-fr.rpm" "${_pkgname}.desktop" "${_pkgname}.sh")
+
+package(){
+
+ install -D -m755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/joxi"
+ install -d "${pkgdir}/usr/lib/joxi"
+ install -D -m755 "${srcdir}/usr/bin/joxi" "${pkgdir}/usr/lib/joxi/joxi"
+
+ install -D -m644 "${srcdir}/etc/ld.so.conf.d/joxi.conf" "${pkgdir}/etc/ld.so.conf.d/joxi.conf"
+ install -D -m644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -D -m644 "${srcdir}/opt/joxi/icon_64.png" "${pkgdir}/usr/share/pixmaps/joxi.png"
+ install -D -m644 "${srcdir}/opt/joxi/icon_light.png" "${pkgdir}/usr/share/pixmaps/joxi_light.png"
+} \ No newline at end of file
diff --git a/joxi.desktop b/joxi.desktop
new file mode 100644
index 000000000000..d50080c18920
--- /dev/null
+++ b/joxi.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Categories=Network;Application;
+Comment=Joxi
+Exec=joxi
+GenericName=joxi
+Name=Joxi
+X-KDE-StartupNotify=true
+MimeType=application/x-designer;
+Icon=joxi.png
+Terminal=false
+Type=Application
+Version=0.1
+Name[ru_RU]=Joxi \ No newline at end of file
diff --git a/joxi.sh b/joxi.sh
new file mode 100644
index 000000000000..cae90ac8d0a4
--- /dev/null
+++ b/joxi.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+#export LD_LIBRARY_PATH=LD_LIBRARY_PATH:/usr/lib/joxi
+#export LD_PRELOAD=/usr/lib/libcurl.so.3
+
+exec /usr/lib/joxi/joxi "$@" \ No newline at end of file