summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-10-24 15:20:48 +0200
committerAlexander F Rødseth2015-10-24 15:20:48 +0200
commit8a8eefc7d99129265a71f83c45b3abe5ca13b964 (patch)
treef5ce8264ed3e488cca26340f45983b59996ed137
parent34069063fc513d00cfb0ccf9d5d0aa6eb2cb8892 (diff)
downloadaur-8a8eefc7d99129265a71f83c45b3abe5ca13b964.tar.gz
Added patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--button_list_segfault.patch13
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d8288251e06..4b9b2c705399 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Oct 24 13:20:32 UTC 2015
pkgbase = joy2key
pkgdesc = Translate joystick movements into keystrokes
pkgver = 1.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://sourceforge.net/projects/joy2key/
arch = x86_64
arch = i686
@@ -9,7 +11,9 @@ pkgbase = joy2key
depends = libx11
depends = xorg-xwininfo
source = http://sourceforge.net/projects/joy2key/files/joy2key/1.6.3/joy2key-1.6.3.tar.bz2
+ source = http://sourceforge.net/p/joy2key/patches/_discuss/thread/e73f20a1/33d7/attachment/button_list_segfault.patch
sha256sums = cf6f452632bb661cf889d843e9ebb9f4fe6ddf4bfe14193ebf74c2d1e2b89f50
+ sha256sums = 10eff65bc28b321e60c4b3573c29c8e9e8c000938111a15e4110f99d8bc2b66c
pkgname = joy2key
diff --git a/PKGBUILD b/PKGBUILD
index bff0c954be75..6bf762f0bc85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,24 @@
pkgname=joy2key
pkgver=1.6.3
-pkgrel=2
+pkgrel=3
pkgdesc='Translate joystick movements into keystrokes'
arch=('x86_64' 'i686')
url='https://sourceforge.net/projects/joy2key/'
license=('GPL2')
depends=('libx11' 'xorg-xwininfo')
-source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('cf6f452632bb661cf889d843e9ebb9f4fe6ddf4bfe14193ebf74c2d1e2b89f50')
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+ "http://sourceforge.net/p/joy2key/patches/_discuss/thread/e73f20a1/33d7/attachment/button_list_segfault.patch")
+sha256sums=('cf6f452632bb661cf889d843e9ebb9f4fe6ddf4bfe14193ebf74c2d1e2b89f50'
+ '10eff65bc28b321e60c4b3573c29c8e9e8c000938111a15e4110f99d8bc2b66c')
+
+prepare() {
+ patch -p0 -i button_list_segfault.patch
+}
build() {
cd "$pkgname-$pkgver"
-
+
./configure --prefix=/usr -x-libraries=/usr/lib
make
}
diff --git a/button_list_segfault.patch b/button_list_segfault.patch
new file mode 100644
index 000000000000..ac47691afb7e
--- /dev/null
+++ b/button_list_segfault.patch
@@ -0,0 +1,13 @@
+Index: joy2key-1.6.3/joy2key.c
+===================================================================
+--- joy2key-1.6.3.orig/joy2key.c 2009-12-06 15:17:43.000000000 -0500
++++ joy2key-1.6.3/joy2key.c 2009-12-06 15:29:10.000000000 -0500
+@@ -576,7 +576,7 @@
+ exit(1);
+ }
+ button_act_counter=0;
+- while((i+1)<=argc && (argv[i+1][0]!='-' ||
++ while((i+1)<argc && (argv[i+1][0]!='-' ||
+ (argv[i+1][0]=='-' && !argv[i+1][1])))
+ {
+ button_actions[button_act_counter]=argtokey(argv[++i]);