summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRohan Bafna2018-07-24 21:08:38 -0400
committerRohan Bafna2018-07-24 21:08:38 -0400
commite24db154af3dda72c1e852caaeb1954d1c7f034c (patch)
treef74281619af33a3d4ba77d18aba213c818c901e0
parent78a2afdf369bc06f526734ccc666e822cfc68fa6 (diff)
downloadaur-e24db154af3dda72c1e852caaeb1954d1c7f034c.tar.gz
Allow package to be run without prepare()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 857ec94086b2..0187d788bebb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = joycon-git
pkgdesc = Joy-Con input driver
pkgver = r99.144b22d
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/riking/joycon
arch = x86_64
license = unknown
@@ -10,6 +10,8 @@ pkgbase = joycon-git
depends = libudev.so
provides = joycon
conflicts = joycon
+ source = src/github.com/riking/joycon::git+https://github.com/riking/joycon.git
+ md5sums = SKIP
pkgname = joycon-git
diff --git a/PKGBUILD b/PKGBUILD
index 2ef60f3e50e8..fd95780acb94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_basename=joycon
pkgname="$_basename-git"
pkgver='r99.144b22d'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Joy-Con input driver'
arch=('x86_64')
url="https://github.com/riking/$_basename"
@@ -12,8 +12,11 @@ makedepends=('go' 'git')
provides=("$_basename")
conflicts=("$_basename")
_gourl="github.com/riking/$_basename/prog4/jcdriver"
+source=("src/github.com/riking/$_basename::git+https://github.com/riking/$_basename.git")
+md5sums=('SKIP')
prepare() {
+ rm -rf "$srcdir/src/github.com/riking/$_basename"
GOPATH="$srcdir" go get -d -u $_gourl
}