summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbernharl2020-10-29 12:41:57 +0100
committerbernharl2020-10-29 12:41:57 +0100
commit77a0b2d0dd4dde2f87b3d619af55240032d821ff (patch)
tree23ee0941d347515f444d3accfc4e876d1746848f
parent1ddd9d5e9a5502bb2230b31aa623cacc4520258f (diff)
downloadaur-77a0b2d0dd4dde2f87b3d619af55240032d821ff.tar.gz
Fix failing build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa9c11a568c1..40d31ad27672 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = joycond-cemuhook-git
pkgdesc = Support for cemuhook's UDP protocol for joycond devices
- pkgver = r41.e9dda77
+ pkgver = r46.857395b
pkgrel = 1
url = https://github.com/joaorb64/joycond-cemuhook
arch = any
@@ -9,6 +9,10 @@ pkgbase = joycond-cemuhook-git
depends = hid-nintendo-dkms
depends = joycond-git
depends = python
+ depends = python-termcolor
+ depends = python-evdev
+ depends = python-dbus-common
+ depends = python-argparse
optdepends = nintendo-udev: Udev rules for switch controllers
conflicts = joycond-cemuhook
source = joycond-cemuhook::git+https://github.com/joaorb64/joycond-cemuhook.git
diff --git a/PKGBUILD b/PKGBUILD
index 78925f66b8a2..f9f665e569b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: nissen22
_pkgname=joycond-cemuhook
pkgname=${_pkgname}-git
-pkgver=r41.e9dda77
+pkgver=r46.857395b
pkgrel=1
pkgdesc="Support for cemuhook's UDP protocol for joycond devices"
arch=("any")
url="https://github.com/joaorb64/joycond-cemuhook"
license=("unknown")
-depends=("hid-nintendo-dkms" "joycond-git" "python")
+depends=("hid-nintendo-dkms" "joycond-git" "python" "python-termcolor" "python-evdev" "python-dbus-common" "python-argparse")
makedepends=("git")
conflicts=("${_pkgname}")
optdepends=('nintendo-udev: Udev rules for switch controllers')
@@ -23,19 +23,15 @@ pkgver() {
}
package() {
- pwd
- install -Dm755 "../run.sh" "${pkgdir}/usr/bin/${pkgname}"
- cd "${_pkgname}"
+ install -Dm755 "${srcdir}/run.sh" "${pkgdir}/usr/bin/${pkgname}"
-
- install -Dm644 "joycond-cemuhook.py" "${pkgdir}/usr/lib/${pkgname}/${pkgname}.py"
-
- install -Dm644 "Nintendo Switch Combined Joy-Cons.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Combined Joy-Cons.json"
- install -Dm644 "Nintendo Switch Left Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Left Joy-Con.json"
- install -Dm644 "Nintendo Switch Pro Controller.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Pro Controller.json"
- install -Dm644 "Nintendo Switch Right Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Right Joy-Con.json"
+ install -Dm644 "${srcdir}/${_pkgname}/joycond-cemuhook.py" "${pkgdir}/usr/lib/${pkgname}/${pkgname}.py"
+ install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Combined Joy-Cons.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Combined Joy-Cons.json"
+ install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Left Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Left Joy-Con.json"
+ install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Pro Controller.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Pro Controller.json"
+ install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Right Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Right Joy-Con.json"
-
- install -Dm644 "README.rst" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ # Probably dont need the readme
+ #install -Dm644 "${srcdir}/${_pkgname}/README.rst" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
}