summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbernharl2020-05-18 11:46:31 +0200
committerbernharl2020-05-18 11:46:31 +0200
commit8988a8510fd39521fbebf1c78c36c16d683d5ecb (patch)
tree43fef892db667dd4e981ed278a3990a4fa0e1e79
downloadaur-8988a8510fd39521fbebf1c78c36c16d683d5ecb.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
-rw-r--r--run.sh2
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd404487a001
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = joycond-cemuhook-git
+ pkgdesc = Support for cemuhook's UDP protocol for joycond devices
+ pkgver = r26.e51f79c
+ pkgrel = 1
+ url = https://github.com/joaorb64/joycond-cemuhook
+ arch = any
+ license = unknown
+ depends = hid-nintendo-dkms
+ depends = joycond-git
+ depends = python
+ conflicts = joycond-cemuhook
+ source = joycond-cemuhook::git+https://github.com/joaorb64/joycond-cemuhook.git
+ sha512sums = SKIP
+
+pkgname = joycond-cemuhook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ec30f112f16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: nissen22
+_pkgname=joycond-cemuhook
+pkgname=${_pkgname}-git
+pkgver=r26.e51f79c
+pkgrel=1
+pkgdesc="Support for cemuhook's UDP protocol for joycond devices"
+arch=("any")
+url="https://github.com/joaorb64/joycond-cemuhook"
+license=("unknown")
+
+depends=("hid-nintendo-dkms" "joycond-git" "python")
+makedepends=()
+conflicts=("${_pkgname}")
+
+source=("${_pkgname}::git+https://github.com/joaorb64/${_pkgname}.git")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ pwd
+ install -Dm755 "../run.sh" "${pkgdir}/usr/bin/${pkgname}"
+ cd "${_pkgname}"
+
+
+ install -Dm644 "joycond-cemuhook.py" "${pkgdir}/usr/lib/${pkgname}/${pkgname}.py"
+
+ install -Dm644 "Nintendo Switch Combined Joy-Cons.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Combined Joy-Cons.json"
+ install -Dm644 "Nintendo Switch Left Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Left Joy-Con.json"
+ install -Dm644 "Nintendo Switch Pro Controller.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Pro Controller.json"
+ install -Dm644 "Nintendo Switch Right Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/Nintendo Switch Right Joy-Con.json"
+
+
+
+ install -Dm644 "README.rst" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+}
diff --git a/run.sh b/run.sh
new file mode 100644
index 000000000000..43043e404c94
--- /dev/null
+++ b/run.sh
@@ -0,0 +1,2 @@
+cd /usr/lib/joycond-cemuhook-git
+python joycond-cemuhook-git.py