summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbernharl2023-02-27 12:29:59 +0100
committerbernharl2023-02-27 12:29:59 +0100
commitae1b88e5f79515017c3738591014134963e5e561 (patch)
tree9d6b8ec4923d95dd3768846c65ebc4daeeb65d84
parenta48e909a20c1030b06bdca5e84eaddf6f003b0e2 (diff)
downloadaur-ae1b88e5f79515017c3738591014134963e5e561.tar.gz
Fix build, credit to chrhasse
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60e7db9950cf..de6ee26bc64e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = joycond-cemuhook-git
pkgdesc = Support for cemuhook's UDP protocol for joycond devices
- pkgver = r46.857395b
+ pkgver = r116.d488022
pkgrel = 1
url = https://github.com/joaorb64/joycond-cemuhook
arch = any
license = unknown
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = joycond-git
depends = python
depends = python-termcolor
@@ -19,8 +22,6 @@ pkgbase = joycond-cemuhook-git
optdepends = hid-nintendo-dkms: Kernel module with switch controller support.
conflicts = joycond-cemuhook
source = joycond-cemuhook::git+https://github.com/joaorb64/joycond-cemuhook.git
- source = run.sh
sha512sums = SKIP
- sha512sums = ccda550ce3daa6e5541135b81872d897b5ba1267b858a61f7e14b83829aefc91c7610fc31a83a8f0e80f56b20dfb53518b774658640b9fd0b105fe4f3c29ad57
pkgname = joycond-cemuhook-git
diff --git a/PKGBUILD b/PKGBUILD
index 515e81aa6f51..0354d02d3076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nissen22
_pkgname=joycond-cemuhook
pkgname=${_pkgname}-git
-pkgver=r46.857395b
+pkgver=r116.d488022
pkgrel=1
pkgdesc="Support for cemuhook's UDP protocol for joycond devices"
arch=("any")
@@ -9,12 +9,12 @@ url="https://github.com/joaorb64/joycond-cemuhook"
license=("unknown")
depends=("joycond-git" "python" "python-termcolor" "python-evdev" "python-dbus-common" "python-argparse" "python-pyudev" "upower" "systemd-libs")
-makedepends=("git")
+makedepends=("git" "python-build" "python-installer" "python-wheel")
conflicts=("${_pkgname}")
optdepends=('nintendo-udev: Udev rules for switch controllers', 'hid-nintendo-dkms: Kernel module with switch controller support.')
-source=("${_pkgname}::git+https://github.com/joaorb64/${_pkgname}.git" "run.sh")
-sha512sums=('SKIP' 'ccda550ce3daa6e5541135b81872d897b5ba1267b858a61f7e14b83829aefc91c7610fc31a83a8f0e80f56b20dfb53518b774658640b9fd0b105fe4f3c29ad57')
+source=("${_pkgname}::git+https://github.com/joaorb64/${_pkgname}.git")
+sha512sums=('SKIP')
pkgver() {
@@ -22,16 +22,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
- install -Dm755 "${srcdir}/run.sh" "${pkgdir}/usr/bin/${pkgname}"
-
- install -Dm644 "${srcdir}/${_pkgname}/joycond-cemuhook.py" "${pkgdir}/usr/lib/${pkgname}/${pkgname}.py"
+build() {
+ cd "$srcdir/joycond-cemuhook"
+ python -m build --wheel --no-isolation --skip-dependency-check
+}
- install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Combined Joy-Cons.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Combined Joy-Cons.json"
- install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Left Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Left Joy-Con.json"
- install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Pro Controller.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Pro Controller.json"
- install -Dm644 "${srcdir}/${_pkgname}/profiles/Nintendo Switch Right Joy-Con.json" "${pkgdir}/usr/lib/${pkgname}/profiles/Nintendo Switch Right Joy-Con.json"
-
- # Probably dont need the readme
- #install -Dm644 "${srcdir}/${_pkgname}/README.rst" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+package() {
+ cd "$srcdir/joycond-cemuhook"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}